Details

    • Type: Task Task
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.99.0, 2.0.0
    • Component/s: None
    • Labels:
      None

      Description

      We need a totem for our t-shirt that is yet to be printed. O'Reilly owns the Clyesdale. We need something else.

      We could have a fluffy little duck that quacks 'hbase!' when you squeeze it and we could order boxes of them from some off-shore sweatshop that subcontracts to a contractor who employs child labor only.....

      Or we could have an Orca (Big!, Fast!, Killer!, and in a poem that Marcy from Salesforce showed me, that was a bit too spiritual for me to be seen quoting here, it had the Orca as the 'Guardian of the Cosmic Memory': i.e. in translation, bigdata).

      1. Screen shot 2011-11-30 at 4.06.17 PM.png
        75 kB
        stack
      2. Orca_479990801.jpg
        47 kB
        stack
      3. photo (2).JPG
        1.58 MB
        stack
      4. HBase Orca Logo.jpg
        150 kB
        Marcy Davis
      5. apache hbase orca logo_Proof 3.pdf
        2.11 MB
        Marcy Davis
      6. apache logo_Proof 8.pdf
        436 kB
        Marcy Davis
      7. krake.zip
        489 kB
        Lars Hofhansl
      8. plus_orca.png
        36 kB
        stack
      9. more_orcas.png
        140 kB
        stack
      10. more_orcas2.png
        171 kB
        stack
      11. Apache_HBase_Orca_Logo_1.jpg
        50 kB
        stack
      12. Apache_HBase_Orca_Logo_Mean_version-3.pdf
        882 kB
        stack
      13. Apache_HBase_Orca_Logo_Mean_version-4.pdf
        882 kB
        stack
      14. Apache_HBase_Orca_Logo_round5.pdf
        897 kB
        stack
      15. orca_free_vector_on_top_66percent_levelled.png
        47 kB
        stack
      16. orca_free_vector_some_selections.png
        150 kB
        stack
      17. orca_free_vector_sheared_rotated_rhs.png
        42 kB
        stack
      18. orca_clipart_freevector_lhs.jpeg
        12 kB
        stack
      19. jumping-orca_rotated.xcf
        76 kB
        stack
      20. jumping-orca_rotated_right.png
        53 kB
        Jean-Marc Spaggiari
      21. proposal_1_logo.png
        89 kB
        Jean-Marc Spaggiari
      22. proposal_1_logo.xcf
        192 kB
        Jean-Marc Spaggiari
      23. proposal_2_logo.png
        82 kB
        Jean-Marc Spaggiari
      24. proposal_2_logo.xcf
        153 kB
        Jean-Marc Spaggiari
      25. proposal_3_logo.png
        82 kB
        Jean-Marc Spaggiari
      26. proposal_3_logo.xcf
        156 kB
        Jean-Marc Spaggiari
      1.
      Orcas to chose from Sub-task Resolved Unassigned
       

        Activity

        Enis Soztutar added a comment -

        Closing this issue after 0.99.0 release.

        Hudson added a comment -

        FAILURE: Integrated in HBase-TRUNK #5439 (See https://builds.apache.org/job/HBase-TRUNK/5439/)
        HBASE-4920 We need a mascot, a totem (stack: rev cd8a9084992a884f2f3e84aa04ea8bd3fdfa2ab9)

        • hbase-server/src/main/resources/hbase-webapps/static/jumping-orca_rotated_12percent.png
        • src/main/site/site.vm
        • src/main/site/resources/images/jumping-orca_rotated.png
        • src/main/site/site.xml
        • src/main/site/resources/images/jumping-orca_rotated.xcf
        • src/main/site/resources/images/jumping-orca_rotated_25percent.png
        • hbase-server/src/main/resources/hbase-webapps/static/hbase_logo_small.png
        • NOTICE.txt
        • src/main/site/resources/images/jumping-orca_rotated_12percent.png
          HBASE-4920 We need a mascot, a totem (stack: rev 80fbcfcd230bc7eaf201f4412f3f2775f1e130c2)
        • hbase-server/src/main/resources/hbase-webapps/static/hbase_logo_small.png
        • pom.xml
        • src/main/site/resources/css/site.css
        • src/main/docbkx/book.xml
        • hbase-server/src/main/resources/hbase-webapps/static/jumping-orca_rotated_12percent.png
        stack added a comment -

        Added an orca to site and to refguide. Added attribution for the image to NOTICES.txt and to refguide in index.

        Its not pretty how I've added it. Feel free to do fixup.

        Resolving as done. Only took a few years (smile).

        stack added a comment -

        Vote closed. See http://search-hadoop.com/m/DHED4qiGlj1 Decided on https://issues.apache.org/jira/secure/attachment/12661956/orca_clipart_freevector_lhs.jpeg and variations. Let me make a patch to add to website and UI as well as adding to notices acknowleding author.

        stack added a comment -

        Let me stick something up on the list Jean-Marc Spaggiari I'm responsible for the mess here.

        Jean-Marc Spaggiari added a comment -

        From the above comments, sound like consensus was page 1 of the PDF. Do we want to add http://www.vectorfree.com/jumping-orca into the vote too? Or stay with page 1?

        Like do you agree on this orca (page 1) as a logo yes/no.

        Or

        Between those 4 orcas rate them 1 to 4 (and then we compile the results)?

        Is the orca on page 1 of the PDF free of rights?

        stack added a comment -

        Jean-Marc Spaggiari We've already run the orca vote and that vote passed. See http://search-hadoop.com/m/DHED4yIYZl1 If you check out the thread it seemed to want to move naturally to the next stage, the vote on the orca representation.

        Jean-Marc Spaggiari added a comment -

        Perfect then.

        Let's start a vote on the mailing list.

        2 options.
        [ ] You are fine with an Orca
        [ ] You are not fine with an Orca

        User mailing list? Or dev only?

        Andrew Purtell added a comment -

        If we can decide on the orca representation, this will move us another step on. It would allow us deploy the representation now.

        JMs proposals all have the same stylized Orca representation. lgtm, +1 Let's move forward. As you say, we can tweak the positioning later.

        stack added a comment -

        I like the #2 and #3. I think they are fine as they are as suggestions. We can tidy up later.

        We're just down to deciding on an embodiment for the logo.

        I'd like to suggest voting on the representation of the orca only, not an 'apache hbase' + orca combination. Trying to vote on the latter will have us in the weeds: "No, it should be on the left!", "nN, on top!!!!".... If we can decide on the orca representation, this will move us another step on. It would allow us deploy the representation now. Work on how the two are combined can come later. It will also vary with context (orca above, orca to the side, orca big or orca small).

        Jean-Marc Spaggiari added a comment -

        Some proposals.
        On 2 and 3, HBase leters are not smooth, but will fix that if it's something we are interested in.

        Jean-Marc Spaggiari added a comment -

        I can work on something. Do we have an high res version of current logo? Or the font available anywhere?

        Andrew Purtell added a comment -

        What's about something like that? Look right, a bit more rotated, jumping over HBase?

        lgtm

        As I read this issue we have consensus on the orca as mascot. We're just down to deciding on an embodiment for the logo.

        This issue has been going on for a while. How about we take what the folks working on this issue think is their preferred option and bring it over to dev@ for a straight up and down vote? If it passes, we have our mascot and updated logo and we can bring this one home.

        Jean-Marc Spaggiari added a comment -

        What's about something like that? Look right, a bit more rotated, jumping over HBase?

        stack added a comment -

        Cleaned up orca and rotated so 'level'. Gimp file.

        stack added a comment -

        Found this creative commons attribute licensed image: http://www.vectorfree.com/jumping-orca

        Posting a few derived images.

        I think attempts at putting orca on existing logo will always be awkward since addition is being done after the fact.

        stack added a comment -

        Attaching a picture just because it is amazing: http://www.pinterest.com/pin/442126888392020299/

        stack added a comment -

        Doug Cutting Now you mention it....

        Andrew Purtell added a comment -

        Yellow elephants aside I do like black

        Doug Cutting added a comment -

        Or a yellow elephant...

        stack added a comment -

        Nicolas Liochon You can't have an orange Orca! Thats like having a panda that is red and green!

        Nicolas Liochon added a comment -

        I like the orange color

        stack added a comment -

        Thanks lads. Nicolas Liochon You would have the orca black, not orange, right?

        Jean-Marc Spaggiari added a comment -

        +1 page 1
        +0 page 2 => HBase for kids
        -1 page 3 => HBase for sad people
        -0 page 4

        thanks for having taken my comment into consideration regarding the teeth.

        What I like with page1 is that it will be easy to reproduce, print, have very small icons, etc. Seems positive (Looking up, not down) positive mouth (not sad). My preferred on this page is the top one because it's more linked to the words.

        My 2¢.

        Andrew Purtell added a comment - - edited

        +1 to Apache_HBase_Orca_Logo_round5 top item page 1

        +1 to Apache_HBase_Orca_Logo_round5 bottom item page 4

        stack added a comment -

        Round 5.

        stack added a comment -

        Let me go back to them lads.

        Aleksandr Shulman added a comment -

        +1 for the Orca.

        Dima Spivak added a comment -

        I agree with Enis, the mean orca looks like it's going to do something nefarious with all your data. That said, the overall design makes it much clearer that it's a whale (versus a few of the more abstract proofs that, as Lars pointed out two years ago, look embryonic). Perhaps the design team can muster an orca in a better mood, Stack?

        Mikhail Antonov added a comment -
        Enis Soztutar added a comment -

        Good stuff. Can we have a nicer orca? I really won't like an evil grin on the logo of an apache project.

        stack added a comment -

        A few variations by the design team who do the stuff where I work.

        Roman Shaposhnik added a comment -

        Stack yup either google docs or survey monkey. And good call on combinations.

        stack added a comment -

        Enis Soztutar Good idea. The vote would be on which 'general' image. I'd then take our logo plus image and then get designer to stamp out the combinations (tall, long, big, small...). The latter came from our Cosmin Lehene

        Enis Soztutar added a comment -

        Open a google docs for voting ?

        stack added a comment -

        More +1s. Ok. So Orca it is given votes here and then the endorsements up in the thread "DISCUSS: We need a mascot, a totem HBASE-4920".

        Now for the hard part, which Orca. A few folks like the 'hockey team' emblem. Lets see if we can get closure on at place holder at least w/o this turning into "engineers doing design" (almost there).

        Doug Meil added a comment -

        +1 for orca.

        Jonathan Hsieh added a comment - - edited

        I withdraw any other options I presented and +1 the orca.

        stack added a comment -

        Weird. I was wandering about today and this issue popped into my head. +1 again.

        Enis Soztutar added a comment -

        Wow we are getting old. Reiterating my +1 for orca.

        Esteban Gutierrez added a comment -

        Two years later I think we should accept the killer whale (Orca) as stack proposed and close this out.

        Roman Shaposhnik added a comment -

        @Jonathan

        "Obviously, You're Not a Golfer" (tm)

        Jonathan Hsieh added a comment -

        I'm also -1 for honey badger, for related technical reasons.

        Andrew Purtell added a comment -

        -1 on Honey Badger. I'm pretty ignorant of Internet memes, for full disclosure, but someone recently showed me the Youtube video behind this one and, frankly, it's one of the dumbest fucking things I've ever seen, to use a technical term.

        Jonathan Hsieh added a comment -

        Epic totem battle: whales vs squid. http://alaskarobotics.com/2009/12/01/whale-vs-squid/

        Esteban Gutierrez added a comment -

        Seems that I forgot to cast my vote:
        +1 Honey Badger

        Marcy Davis added a comment -

        Let me know when you guys figure out what image you want to use so that I can incorporate this into a tshirt design

        stack added a comment -

        more

        stack added a comment -

        Still not right but uploading anyways (the orca is too fuzzy and doesn't have right aspect... also needs to be more evil looking)

        stack added a comment -

        The red one is not bad (purple too cartoony and the other too complicated).

        On Marcy's latest, I think first set while graphically clean, they have lost too much detail and hard now to identify as an orca in particular. Option 5 is not bad but not sure this an orca either w/ the blunt nose. I'd say option 6 the best of the lot.

        Looking around more it looks like we could 'buy' these as is:

        http://www.shutterstock.com/pic-58643317/stock-vector-vector-killer-whale-represented-in-the-form-of-a-tattoo.html

        http://depositphotos.com/2900573/stock-illustration-Killer-whale-tattoo.html

        http://www.canstockphoto.com/whale-tattoo-3058609.html

        http://www.canstockphoto.com/orca-killer-whale-2297275.html

        http://4.bp.blogspot.com/_HBjr0PcdZW4/TIge5Uok9eI/AAAAAAAAA8Q/0AdMNtuhRaY/s400/pm006-orca7.png

        http://www.bigstockphoto.com/image-27015218/stock-vector-orca-killer-whale-cartoon-vector-illustratio

        http://www.graphicsfactory.com/Clip_Art/Animals/Fish/funny_water_animals_053_377466.html

        This one, the second, inverted might work http://depositphotos.com/2900573/stock-illustration-Killer-whale-tattoo.html, so its rising over the hbase logo from the right.

        Lars Hofhansl added a comment -

        Here's three squid/octopus/kraken images that I found that didn't look too shabby.
        (Although I like this octupus idea less and less)

        Lars Hofhansl added a comment -

        6 & 7 look too much like embryos for my taste. I like #2 best, although it's also a bit too curled up.

        Marcy Davis added a comment -

        see the apache logo_Proof 8.pdf 11/Feb/12 attachment

        Marcy Davis added a comment -

        see the apache logo_Proof 8.pdf 11/Feb/12 attachment

        Marcy Davis added a comment -

        I like the 1,2&3 orca the best, and the 6&7 orca second. What do you guys think?

        Jonathan Hsieh added a comment - - edited

        I feel the "cyber" look and the hard edges of the wordmark doesn't quite fit with the roundness of the image but like the general idea (maybe a "sharper" style for the same idea).

        @Stack http://en.wikipedia.org/wiki/Vancouver_Canucks

        @Lars Actual pacific northwest native american totem poles with octopus/squid
        http://users.imag.net/~sry.jkramer/nativetotems/common.htm
        http://www.flickr.com/photos/lostviking/3419653151/

        Giant squids are pretty close to the International Orange (Engineering) color.
        http://blogs.sfweekly.com/thesnitch/2008/01/breaking_giant_cartoon_squid_a.php

        Enis Soztutar added a comment -

        Orca +1, Hadoop -> Elephant, HBase -> Orca makes sense in my view. I liked design option 2's as well, can your friend put together the logo with the HBase text, to see how they look together.

        Marcy Davis added a comment -

        Here are a few other Orca design options (2 in black and white).

        Marcy Davis added a comment -

        I will have my friend play around with the Orca image some more based on everyone's comments. @Lars Hofhansl, do you have an image of an octupus you want to suggest?

        stack added a comment -

        I like circle. I like the monochormatic take. I wonder if black and white might not be better since then its more identifiably an orca. It does make me think of a hockey team for some reason. It doesn't seem to go well w/ the 'apache hbase'. Maybe inverted and on right side would help and perhaps smaller. Tell your buddy thanks Marcy for helping move this along.

        Lars Hofhansl added a comment -

        I still think some of octopus would be great for HBase

        Ian Varley added a comment -

        I'd guess that the one on the left is a dorsal fin (on the back) and the other is a pectoral fin (on the side); it's a side view of the Orca.

        ... and no, I didn't know the words for those off the top of my head, I looked them up.

        Ted Yu added a comment -

        Orca design looks good.
        Is there a reason behind one fin being bigger than the other ?

        Marcy Davis added a comment -

        My friend came up with this Orca design. Thoughts?

        stack added a comment -

        From tumblr eng (+Danielle)... multiple entries (gansta rubber duckie, smug frog, purple octopus, etc.)

        stack added a comment -
        Gary Helmling added a comment -

        +1 for honey badger. It is bad ass.

        Otis Gospodnetic added a comment -

        I'm all for marine angle.
        Sailfish is the fastest fish and can swim over 110 km/h!
        http://images.google.com/search?q=sailfish
        When in attack mode, they change colour.... kind of hard to show on a t-shirt, but cool. And it will eat your fluffy little duck, Stack!

        stack added a comment -

        @Roman My son is called honey badger so I think I'd get confused in honey badger conversations not knowing to what folks are referring: hbase, my nipper, or the youtube star.

        Roman Shaposhnik added a comment -

        Orca is fine, but a bad ass honey badger now owns my heart as far as mascots for OS projects are concerned
        http://www.youtube.com/watch?v=4r7wHMg5Yjg


          People

          • Assignee:
            Unassigned
            Reporter:
            stack
          • Votes:
            2 Vote for this issue
            Watchers:
            27 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development