Uploaded image for project: 'HBase'
  1. HBase
  2. HBASE-4781

Pom update to use the new versions of surefire & junit

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 0.94.0
    • Fix Version/s: 0.94.0
    • Component/s: build
    • Labels:
      None

      Description

      Upgrading surefire & junit requires some .pom modifications.

      1. 4781_trunk_pom.v6.patch
        15 kB
        Nicolas Liochon
      2. 4781_trunk_pom.v2.patch
        14 kB
        Nicolas Liochon
      3. 4781_trunk_pom.patch
        13 kB
        Nicolas Liochon

        Issue Links

          Activity

          hudson Hudson added a comment -

          Integrated in HBase-TRUNK #2462 (See https://builds.apache.org/job/HBase-TRUNK/2462/)
          HBASE-4781 Pom update to use the new versions of surefire & junit

          tedyu :
          Files :

          • /hbase/trunk/pom.xml
          yuzhihong@gmail.com Ted Yu added a comment -

          Integrated to TRUNK.

          Thanks for the patch N.

          nkeywal Nicolas Liochon added a comment -

          org.apache.hadoop.hbase.client.TestAdmin: Caused by: java.io.IOException: Too many open files
          org.apache.hadoop.hbase.client.TestShell: failed on trunk as well

          Can be committed imho

          hadoopqa Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12504361/4781_trunk_pom.v6.patch
          against trunk revision .

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 5 new or modified tests.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          -1 findbugs. The patch appears to introduce 60 new Findbugs (version 1.3.9) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          -1 core tests. The patch failed these unit tests:
          org.apache.hadoop.hbase.client.TestAdmin
          org.apache.hadoop.hbase.client.TestShell

          Test results: https://builds.apache.org/job/PreCommit-HBASE-Build/311//testReport/
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/311//artifact/trunk/patchprocess/newPatchFindbugsWarnings.html
          Console output: https://builds.apache.org/job/PreCommit-HBASE-Build/311//console

          This message is automatically generated.

          nkeywal Nicolas Liochon added a comment -

          Surefire issue, exists already on the previous version (=> not linked to category or any of our changes). I will provide a patch soon.

          nkeywal Nicolas Liochon added a comment -

          Ok, the problem is not really the two tests that failed but the wrong execution time reported by the final report. So it cannot be committed yet.

          hadoopqa Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12504046/4781_trunk_pom.v2.patch
          against trunk revision .

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 5 new or modified tests.

          -1 javadoc. The javadoc tool appears to have generated -163 warning messages.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          -1 findbugs. The patch appears to introduce 51 new Findbugs (version 1.3.9) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          -1 core tests. The patch failed these unit tests:
          org.apache.hadoop.hbase.master.TestDistributedLogSplitting
          org.apache.hadoop.hbase.replication.TestReplication

          Test results: https://builds.apache.org/job/PreCommit-HBASE-Build/279//testReport/
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/279//artifact/trunk/patchprocess/newPatchFindbugsWarnings.html
          Console output: https://builds.apache.org/job/PreCommit-HBASE-Build/279//console

          This message is automatically generated.

          nkeywal Nicolas Liochon added a comment -

          This pom patch makes it connect to Gary's private repo for surefire & junit.

          small & medium & large categories are included but not (yet!) activated by default.

          nkeywal Nicolas Liochon added a comment -

          Used for testing surefire & junit private version. Not to be commited immediatly.

          "mvn test" for small & medium test. Generates two reports.

          "mvn verify" or "mvn test -P runAllTests" for all tests. The former does not run the large tests if the small or medium failed.


            People

            • Assignee:
              nkeywal Nicolas Liochon
              Reporter:
              nkeywal Nicolas Liochon
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development