Uploaded image for project: 'HBase'
  1. HBase
  2. HBASE-4719

HBase script assumes pre-Hadoop 0.21 layout of jar files

VotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

Details

    • Bug
    • Status: Closed
    • Major
    • Resolution: Fixed
    • 0.92.0
    • 0.92.0
    • scripts
    • Reviewed

    Description

      The following in the bin/hbase:

      HADOOPCPPATH=$(append_path "${HADOOPCPPATH}" `ls ${HADOOP_HOME}/hadoop-core*.jar`)
      

      assumes a pre-21 Hadoop layout. It'll be better to dynamically account for
      either hadoop-core* or hadoop-common*, hadoop-hdfs*, hadoop-mapreduce*

      Attachments

        1. HBASE-4719.patch.txt
          0.9 kB
          Roman Shaposhnik

        Activity

          This comment will be Viewable by All Users Viewable by All Users
          Cancel

          People

            rvs Roman Shaposhnik
            rvs Roman Shaposhnik
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Issue deployment