HBase
  1. HBase
  2. HBASE-4654

[replication] Add a check to make sure we don't replicate to ourselves

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.90.4
    • Fix Version/s: 0.98.0, 0.96.1, 0.94.14
    • Component/s: None
    • Labels:
      None
    • Tags:
      replication

      Description

      It's currently possible to add a peer for replication and point it to the local cluster, which I believe could very well happen for those like us that use only one ZK ensemble per DC so that only the root znode changes when you want to set up replication intra-DC.

      I don't think comparing just the cluster ID would be enough because you would normally use a different one for another cluster and nothing will block you from pointing elsewhere.
      Comparing the ZK ensemble address doesn't work either when you have multiple DNS entries that point at the same place.

      I think this could be resolved by looking up the master address in the relevant znode as it should be exactly the same thing in the case where you have the same cluster.

      1. 4654-trunk.txt
        0.8 kB
        Lars Hofhansl
      2. HBASE-4654-trunk-v0.patch
        1 kB
        Demai Ni
      3. HBASE-4654-trunk-v0.patch
        1 kB
        Demai Ni
      4. HBASE-4654-0.94-v0.patch
        1.0 kB
        Demai Ni
      5. HBASE-4654-trunk-v0.patch
        1 kB
        stack
      6. HBASE-4654-0.96-v0.patch
        1 kB
        Demai Ni

        Activity

        gaojinchao added a comment -

        @J-D
        Can we fix only in trunk or 0.92?
        We can use ClusterId to judge whether is a same cluster.

        Jean-Daniel Cryans added a comment -

        By comparing the master address in the znode it can be done in 0.90, for the others we can just use the ClusterId yeah.

        Lars Hofhansl added a comment -

        For 0.92 and trunk, this should be sufficient (but haven't tested, yet)

        gaojinchao added a comment -

        Do we need throw exceptin in api "addPeer"?

        Lars Hofhansl added a comment -

        I was thinking about that, would certainly be more user friendly. That means, though, that we already have to get the peerClusterId at that time, which in turns means that we have to make the connection to the peer cluster's ZK right away.

        On the other hand, I don't expect that to be a common scenario, just a safeguard against user error.

        ramkrishna.s.vasudevan added a comment -

        Moving to 0.90.7 and 0.92.1.. Please pull back if you think differently.

        Demai Ni added a comment -

        hi, folks,

        I encountered the same problem last week.
        email@dev list :http://mail-archives.apache.org/mod_mbox/hbase-dev/201310.mbox/%3CCAOEq2C5g7-8MfUBSdzeTgzNFJU6pkP3cMY_62N18z3pRXe2SMw%40mail.gmail.com%3E

        My case was (on hbase 0.94.9) that a zoo.cfg was put under ./hbase/conf.

        I was thinking about to open a jira for the sanity check (exactly the same idea), and glad to find this jira before opening a dup.

        Just curious that why this jira hasn't been pushed into trunk and 0.94 yet since no strong objection in the comments. Well, understand that this is a rare case, but a couple line of code can save someone(like me) several hours of debugging, which sounds a good idea.

        The jira is still unassigned. I can do some testing and upload an up-to-date patch (both trunk and 0.94) if everyone is busy.

        thanks

        P.S. per the comments about checking 'addPeer'. I tried it(add_peer with zookeeper info of the master cluster), which won't cause the UUID case in replicateSource. So far, the only case I am aware of is the one reported with incorrect zoo.cfg

        Demai

        Demai Ni added a comment -

        seems everyone is busy, I will provide an up-to-date patch.

        stack added a comment -

        Demai Ni Thanks. Looks like a fix we should get in.

        Demai Ni added a comment -

        patch for trunk.

        stack added a comment -

        Patch LGTM. Waiting on hadoopqa.

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12613253/HBASE-4654-trunk-v0.patch
        against trunk revision .

        +1 @author. The patch does not contain any @author tags.

        -1 tests included. The patch doesn't appear to include any new or modified tests.
        Please justify why no new tests are needed for this patch.
        Also please list what manual steps were performed to verify this patch.

        +1 hadoop1.0. The patch compiles against the hadoop 1.0 profile.

        +1 hadoop2.0. The patch compiles against the hadoop 2.0 profile.

        -1 javadoc. The javadoc tool appears to have generated 1 warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        +1 lineLengths. The patch does not introduce lines longer than 100

        -1 site. The patch appears to cause mvn site goal to fail.

        -1 core tests. The patch failed these unit tests:
        org.apache.hadoop.hbase.master.TestRestartCluster

        Test results: https://builds.apache.org/job/PreCommit-HBASE-Build/7815//testReport/
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/7815//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-prefix-tree.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/7815//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-client.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/7815//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-common.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/7815//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-protocol.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/7815//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-server.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/7815//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-hadoop1-compat.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/7815//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-examples.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/7815//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-thrift.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/7815//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-hadoop-compat.html
        Console output: https://builds.apache.org/job/PreCommit-HBASE-Build/7815//console

        This message is automatically generated.

        Demai Ni added a comment -

        I didn't find any javadoc warning related with this patch (a few warnings for Bytes.java, CellUtil.java, which have been there before)

        about the UT failure: org.apache.hadoop.hbase.master.TestRestartCluster, the stacktrace also doesn't indicate any relationship with this patch, probably caused by unstable environment
        java.io.IOException: Shutting down
        .....
        at org.apache.hadoop.hbase.master.TestRestartCluster.testRestartClusterAfterKill(TestRestartCluster.java:78)

        I will submit to HadoopQA one more time.

        Demai Ni added a comment -

        upload patch for 0.94

        stack added a comment -

        Adding the trunk patch after the 0.94 patch; hadoopqa picks up the last uploaded.

        Demai Ni added a comment -

        St.ack, I didn't realize this. Appreciate the help... Demai

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12613316/HBASE-4654-trunk-v0.patch
        against trunk revision .

        +1 @author. The patch does not contain any @author tags.

        -1 tests included. The patch doesn't appear to include any new or modified tests.
        Please justify why no new tests are needed for this patch.
        Also please list what manual steps were performed to verify this patch.

        +1 hadoop1.0. The patch compiles against the hadoop 1.0 profile.

        +1 hadoop2.0. The patch compiles against the hadoop 2.0 profile.

        -1 javadoc. The javadoc tool appears to have generated 1 warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        +1 lineLengths. The patch does not introduce lines longer than 100

        -1 site. The patch appears to cause mvn site goal to fail.

        +1 core tests. The patch passed unit tests in .

        Test results: https://builds.apache.org/job/PreCommit-HBASE-Build/7823//testReport/
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/7823//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-prefix-tree.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/7823//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-client.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/7823//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-common.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/7823//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-protocol.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/7823//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-server.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/7823//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-hadoop1-compat.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/7823//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-examples.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/7823//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-thrift.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/7823//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-hadoop-compat.html
        Console output: https://builds.apache.org/job/PreCommit-HBASE-Build/7823//console

        This message is automatically generated.

        Ted Yu added a comment -

        Integrated to trunk.

        Thanks for the patch, Demai.

        Thanks for the review, Stack.

        Lars Hofhansl added a comment -

        +1 on 0.94. Stack, I assume you want this in 0.96?

        Demai Ni added a comment -

        Lars Hofhansl, thanks for the reminder. here is the 0.96 patch

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12613513/HBASE-4654-0.96-v0.patch
        against trunk revision .

        +1 @author. The patch does not contain any @author tags.

        -1 tests included. The patch doesn't appear to include any new or modified tests.
        Please justify why no new tests are needed for this patch.
        Also please list what manual steps were performed to verify this patch.

        -1 patch. The patch command could not apply the patch.

        Console output: https://builds.apache.org/job/PreCommit-HBASE-Build/7836//console

        This message is automatically generated.

        Hudson added a comment -

        SUCCESS: Integrated in HBase-TRUNK-on-Hadoop-2.0.0 #836 (See https://builds.apache.org/job/HBase-TRUNK-on-Hadoop-2.0.0/836/)
        HBASE-4654 [replication] Add a check to make sure we don't replicate to ourselves (Demai) (tedyu: rev 1541279)

        • /hbase/trunk/hbase-server/src/main/java/org/apache/hadoop/hbase/replication/regionserver/ReplicationSource.java
        Hudson added a comment -

        SUCCESS: Integrated in HBase-TRUNK #4679 (See https://builds.apache.org/job/HBase-TRUNK/4679/)
        HBASE-4654 [replication] Add a check to make sure we don't replicate to ourselves (Demai) (tedyu: rev 1541279)

        • /hbase/trunk/hbase-server/src/main/java/org/apache/hadoop/hbase/replication/regionserver/ReplicationSource.java
        Lars Hofhansl added a comment -

        Checked with Stack offline. Committed to 0.94 and 0.96 as well.

        Hudson added a comment -

        SUCCESS: Integrated in HBase-0.94-security #335 (See https://builds.apache.org/job/HBase-0.94-security/335/)
        HBASE-4654 [replication] Add a check to make sure we don't replicate to ourselves (Demai Ni) (larsh: rev 1541806)

        • /hbase/branches/0.94/src/main/java/org/apache/hadoop/hbase/replication/regionserver/ReplicationSource.java
        Hudson added a comment -

        SUCCESS: Integrated in HBase-0.94 #1201 (See https://builds.apache.org/job/HBase-0.94/1201/)
        HBASE-4654 [replication] Add a check to make sure we don't replicate to ourselves (Demai Ni) (larsh: rev 1541806)

        • /hbase/branches/0.94/src/main/java/org/apache/hadoop/hbase/replication/regionserver/ReplicationSource.java
        Hudson added a comment -

        SUCCESS: Integrated in hbase-0.96 #189 (See https://builds.apache.org/job/hbase-0.96/189/)
        HBASE-4654 [replication] Add a check to make sure we don't replicate to ourselves (Demai Ni) (larsh: rev 1541805)

        • /hbase/branches/0.96/hbase-server/src/main/java/org/apache/hadoop/hbase/replication/regionserver/ReplicationSource.java
        Hudson added a comment -

        SUCCESS: Integrated in hbase-0.96-hadoop2 #119 (See https://builds.apache.org/job/hbase-0.96-hadoop2/119/)
        HBASE-4654 [replication] Add a check to make sure we don't replicate to ourselves (Demai Ni) (larsh: rev 1541805)

        • /hbase/branches/0.96/hbase-server/src/main/java/org/apache/hadoop/hbase/replication/regionserver/ReplicationSource.java

          People

          • Assignee:
            Demai Ni
            Reporter:
            Jean-Daniel Cryans
          • Votes:
            0 Vote for this issue
            Watchers:
            8 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development