HBase
  1. HBase
  2. HBASE-4136

Load balancer may not have a chance to run due to RegionsInTransition being non-empty

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Invalid
    • Affects Version/s: 0.90.3
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      I observed in our staging cluster that load balancer didn't run for a long period of time.
      I saw the following in master log:

      2011-07-24 15:56:32,333 DEBUG org.apache.hadoop.hbase.master.HMaster: Not running balancer because 2 region(s) in transition: {4e7416833e3bbd6a8ade26f6986529bf=TABLE-1311419946465,E'\xFD\xDDu\xC3\x894\xF4$\xC0K\xA3!\x82\xB9\xD0\x7F|>\xAC\xDA81\xB6\x92\xED\xA9\x9C\xA6^\xF4,1311419961631.4e7416833e3bbd6a8ade26f6986529bf. state=PENDING_CLOSE, ts=...
      

      This means we need to find a better way of permitting one balance run at a time. In HMaster.balance():

            if (this.assignmentManager.isRegionsInTransition()) {
      

        Activity

        stack added a comment -

        Resolving as invalid. The behavior is by design.

        stack added a comment -

        Yeah, the balancer will not run while RIT. We don't want balancer moving stuff when the regions in flight might be making things right, at least not yet, not till our balancer algorithm gets a bit smarter


          People

          • Assignee:
            Unassigned
            Reporter:
            Ted Yu
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development