HBase
  1. HBase
  2. HBASE-4129

hbase-3872 added a warn message 'CatalogJanitor: Daughter regiondir does not exist' that is triggered though its often legit that daughter is not present

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.90.4
    • Fix Version/s: 0.90.4
    • Component/s: None
    • Labels:
      None

      Description

      If a daughter region is split before the catalog janitor runs, we'll see:

      2011-07-22 16:10:26,398 WARN org.apache.hadoop.hbase.master.CatalogJanitor: Daughter regiondir does not exist: hdfs://sv4borg227:10000/hbase/TestTable/a1023b2b00fe44c86bd8ae3633f531fa
      

      Its legit that the daughter region does not exist in this case (it was just cleaned up by the catalogjanitor).

        Activity

        stack added a comment -

        So, I think the issue is that the HRegionInfo comparator is sorting daughters' before parents so we process daughter first, then parent. Rather than change the HRI comparator, a radical move, I just made a version of it over in CatalogJanitor that will sort parents first. This should make it so I do not have to relax requirement that a daughter region exist before I can remove parent. Testing on cluster now.

        stack added a comment -

        Committed trunk and branch.

        Hudson added a comment -

        Integrated in HBase-TRUNK #2049 (See https://builds.apache.org/job/HBase-TRUNK/2049/)
        HBASE-4129 hbase-3872 added a warn message 'CatalogJanitor: Daughter regiondir does not exist' that is triggered though its often legit that daughter is not present

        stack :
        Files :

        • /hbase/trunk/src/main/java/org/apache/hadoop/hbase/master/CatalogJanitor.java
        • /hbase/trunk/CHANGES.txt

          People

          • Assignee:
            stack
            Reporter:
            stack
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development