HBase
  1. HBase
  2. HBASE-3390

Double-close makes for double-assign of a region

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      I see double-assign during a rolling restart test. Its happening when master joins existing cluster... half the RSs have reported in but its taking on splits anyways (I have it splitting and balancing continuously). A split comes in immediately followed by a balance. What I think is happening is that the split comes in and clears a CLOSING from RIT as part of its cleanup of parent region references. This is messing up the run of balancers' close somehow; we're getting node created and children changed zk events and this makes somehow for the double closed.

      I'm enabling zk logging and will try harder to hunt this one down.

      Not creating as BLOCKER on 0.90.0 because I think its ok to disable balancer while rolling restart is going on – and the current rolling restart is a horror anyways doing its maximmal region moving.

        Activity

        stack added a comment -

        Here is extract from Master. I checked RS log and its doing nice clean close.

        Andrew Purtell added a comment -

        Reopen or file new issue if relevant with modern HBase versions


          People

          • Assignee:
            Unassigned
            Reporter:
            stack
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development