Uploaded image for project: 'HBase'
  1. HBase
  2. HBASE-3386

NPE in TableRecordReaderImpl.restart

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.90.0
    • Component/s: None
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      I was running some testing on a already busy cluster and my clients in the mappers sometimes aren't able to create an HTable because of ConnectionLoseException. The code logs that as an error but still continues with a null HTable then this happens:

      java.lang.NullPointerException
      	at org.apache.hadoop.hbase.mapreduce.TableRecordReaderImpl.restart(TableRecordReaderImpl.java:58)
      	at org.apache.hadoop.hbase.mapreduce.TableRecordReaderImpl.init(TableRecordReaderImpl.java:67)
      	at org.apache.hadoop.hbase.mapreduce.TableRecordReader.init(TableRecordReader.java:57)
      	at org.apache.hadoop.hbase.mapreduce.TableInputFormatBase.createRecordReader(TableInputFormatBase.java:108)
      

      Needs to be prettier.

        Attachments

        1. HBASE-3386.patch
          0.9 kB
          Jean-Daniel Cryans

          Activity

            People

            • Assignee:
              jdcryans Jean-Daniel Cryans
              Reporter:
              jdcryans Jean-Daniel Cryans
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: