Uploaded image for project: 'HBase'
  1. HBase
  2. HBASE-319

[hbase] Some minor improvements to changes in HADOOP-2443

    XMLWordPrintableJSON

Details

    • Bug
    • Status: Closed
    • Minor
    • Resolution: Fixed
    • None
    • None
    • None
    • None

    Description

      Stack made a number of suggestions for improvements in the code changes from HADOOP-2443:

      Here in HConnectionManager:

      + scannerId = server.openScanner(
      + metaLocation.getRegionInfo().getRegionName(),
      + COLUMN_FAMILY_ARRAY, EMPTY_START_ROW, LATEST_TIMESTAMP,
      + null);

      ... EMPTY_START_ROW will work but 'startRow' would be easier to read (It'd work too - right?).

      Here:

      + } while (startRow.compareTo(EMPTY_START_ROW) != 0);

      .. EMPTY_ROW or a new define, LAST_ROW, would have been more readable, don't you think?

      This 999... 'trick' should be done as a method - in HTableInfo? - since you do it twice:

      + Text tableKey = new Text(tableName.toString() + ",,99999999999999");

      Attachments

        1. 2599.patch
          2 kB
          Bryan Duxbury
        2. 2599-v2.patch
          2 kB
          Bryan Duxbury

        Issue Links

          Activity

            People

              Unassigned Unassigned
              bryanduxbury Bryan Duxbury
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: