HBase
  1. HBase
  2. HBASE-26

[hbase] TestTableIndex: variable substitution depth too large: 20

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Trivial Trivial
    • Resolution: Won't Fix
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: test
    • Labels:
      None

      Description

      See 'stack - 30/Oct/07 09:51 PM' comment over in HADOOP-2083 for description of an error or see here: http://lucene.zones.apache.org:8080/hudson/job/Hadoop-Patch/970/testReport/org.apache.hadoop.hbase.mapred/TestTableIndex/testTableIndex/

      Seems like its a rare occurrence.

        Activity

        stack added a comment -

        Nightly build http://lucene.zones.apache.org:8080/hudson/job/Hadoop-Nightly/297/console dumps out all the config. for indexing but no accompanying exception

        Jim Kellerman added a comment -

        Hadoop-Nightly 297 failed for a different reason:

        • The region server's lease expired (Why? was the heartbeat thread starved?)
        • The region server gets a call startup message
        • The master splits the region server's log and deletes it.

        I think that when the region server called log.closeAndDelete(), it got an exception (because the file no longer existed) at that point it said "error restarting server" and quit. From there on the master is just looping because there is no region server to talk to

        We should probably just log an error for log.closeAndDelete() and proceed with region server restart.

        Also for that test, we should probably increase the lease timeout and make the lease timeout check happen less frequently accordingly

        stack added a comment -

        Good stuff. Want to make a new issue J? Lets keep this one for repeats of the 'substitution depth too large' exception.

        Ning Li added a comment -

        I think the problem is caused by IndexConfiguration extending Hadoop's Configuration and Hadoop's Configuration loading hadoop-default.xml and hadoop-site.xml. IndexConfiguration does not need the two Hadoop configuration files, but Hadoop's Configuration does not provide a way not to load the files. Should we ask Hadoop to allow the change?

        stack added a comment -

        If you can't do the interpolation before adding the IndexConfiguration variable, yes. Or, you could change the seemingly arbitrary upper bound of 20 interpolations.

        Jim Kellerman added a comment -

        Downgrading priority since it has been some time since this problem was last observed.

        Bryan Duxbury added a comment -

        Has this problem ever shown up again? It's pretty old. We should close it.

        stack added a comment -

        Not seen since. I'd say we haven't seen it because this functionality is not being used. I can see how it might happen in a real-world use case. Lets close this issue and open a new one when we get a complaint.


          People

          • Assignee:
            Unassigned
            Reporter:
            stack
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development