Uploaded image for project: 'HBase'
  1. HBase
  2. HBASE-25728

[hbase-thirdparty] Upgrade Netty library to >= 4.1.60 due to security vulnerability CVE-2021-21295

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: thirdparty-3.5.1
    • Component/s: thirdparty
    • Labels:
      None
    • Hadoop Flags:
      Reviewed
    • Release Note:
      Netty is upgrade to 4.1.63.Final due to security vulnerability CVE-2021-21295.

      Description

      We don't have a direct exposure to this vulnerability but vulnerability scanners aware of the CVE database may flag it.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                apurtell Andrew Kyle Purtell
                Reporter:
                apurtell Andrew Kyle Purtell
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: