Uploaded image for project: 'HBase'
  1. HBase
  2. HBASE-24752

NPE/500 accessing webui on master startup

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.3.0
    • Fix Version/s: 3.0.0-alpha-1, 2.3.1, 2.4.0, 2.2.6
    • Component/s: master
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      I got a 500 error while accessing the master web ui (non-backup master) during startup.

      2020-07-21 18:56:39,762 WARN org.eclipse.jetty.servlet.ServletHandler: /master-status
      java.lang.NullPointerException
              at org.apache.hadoop.hbase.tmpl.master.MasterStatusTmplImpl.renderNoFlush(MasterStatusTmplImpl.java:339)
              at org.apache.hadoop.hbase.tmpl.master.MasterStatusTmpl.renderNoFlush(MasterStatusTmpl.java:397)
              at org.apache.hadoop.hbase.tmpl.master.MasterStatusTmpl.render(MasterStatusTmpl.java:388)
              at org.apache.hadoop.hbase.master.MasterStatusServlet.doGet(MasterStatusServlet.java:79)
              at javax.servlet.http.HttpServlet.service(HttpServlet.java:687)
      ...
      

      MasterStatusTmplImpl.java:339 appears to align with MasterStatusTmpl.jamon:227:

                <%if master.getMasterCoprocessorHost().findCoprocessor("RSGroupAdminEndpoint") != null &&
                  serverManager.getOnlineServersList().size() > 0 %>
      

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                wenfeiyi666 wenfeiyi666
                Reporter:
                ndimiduk Nick Dimiduk
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: