Uploaded image for project: 'HBase'
  1. HBase
  2. HBASE-24631

Loosen Dockerfile pinned package versions of the "debian-revision"

    XMLWordPrintableJSON

    Details

    • Type: Task
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 3.0.0-alpha-1
    • Fix Version/s: 3.0.0-alpha-1, 2.3.0
    • Component/s: build
    • Labels:
      None
    • Hadoop Flags:
      Reviewed
    • Release Note:
      Hide
      <!-- markdown -->
      Update our package version numbers throughout the Dockerfiles to be pinned to their epic:upstream-version components only. Previously we'd specify the full debian package version number, including the debian-revision. This lead to instability as debian packaging details changed.
      See also [man deb-version](http://manpages.ubuntu.com/manpages/xenial/en/man5/deb-version.5.html)
      Show
      <!-- markdown --> Update our package version numbers throughout the Dockerfiles to be pinned to their epic:upstream-version components only. Previously we'd specify the full debian package version number, including the debian-revision. This lead to instability as debian packaging details changed. See also [man deb-version]( http://manpages.ubuntu.com/manpages/xenial/en/man5/deb-version.5.html )

      Description

      Portions of PR jobs have started failing. From the log, our versions of curl is no longer available in ubuntu package servers.

      [2020-06-24T21:41:59.524Z] ============================================================================
      [2020-06-24T21:41:59.524Z] ============================================================================
      [2020-06-24T21:41:59.524Z]                            Docker Image Creation
      [2020-06-24T21:41:59.524Z] ============================================================================
      [2020-06-24T21:41:59.524Z] ============================================================================
      [2020-06-24T21:41:59.524Z] 
      [2020-06-24T21:41:59.524Z] 
      [2020-06-24T21:41:59.524Z] Sending build context to Docker daemon  18.99kB
      
      [2020-06-24T21:41:59.524Z] Step 1/60 : FROM ubuntu:18.04 AS BASE_IMAGE
      [2020-06-24T21:42:00.233Z] 18.04: Pulling from library/ubuntu
      [2020-06-24T21:42:00.943Z] Digest: sha256:86510528ab9cd7b64209cbbe6946e094a6d10c6db21def64a93ebdd20011de1d
      [2020-06-24T21:42:00.943Z] Status: Downloaded newer image for ubuntu:18.04
      [2020-06-24T21:42:00.943Z]  ---> 8e4ce0a6ce69
      [2020-06-24T21:42:00.943Z] Step 2/60 : SHELL ["/bin/bash", "-o", "pipefail", "-c"]
      [2020-06-24T21:42:00.943Z]  ---> Using cache
      [2020-06-24T21:42:00.943Z]  ---> 9170e78be248
      [2020-06-24T21:42:00.943Z] Step 3/60 : RUN DEBIAN_FRONTEND=noninteractive apt-get -qq update &&   DEBIAN_FRONTEND=noninteractive apt-get -qq install --no-install-recommends -y     ca-certificates=20180409     curl=7.58.0-2ubuntu3.8     locales=2.27-3ubuntu1     bash=4.4.18-2ubuntu1.2     build-essential=12.4ubuntu1     diffutils=1:3.6-1     git=1:2.17.1-1ubuntu0.7     rsync=3.1.2-2.1ubuntu1     tar=1.29b-2ubuntu0.1     wget=1.19.4-1ubuntu2.2     bats=0.4.0-1.1     libperl-critic-perl=1.130-1     python3=3.6.7-1~18.04     python3-pip=9.0.1-2.3~ubuntu1.18.04.1     python3-setuptools=39.0.1-2     ruby=1:2.5.1     ruby-dev=1:2.5.1     shellcheck=0.4.6-1     &&     apt-get clean &&     rm -rf /var/lib/apt/lists/*
      [2020-06-24T21:42:02.413Z]  ---> Running in 87d1f25abbc4
      [2020-06-24T21:42:11.760Z] E: Version '7.58.0-2ubuntu3.8' for 'curl' was not found
      [2020-06-24T21:42:12.471Z] The command '/bin/bash -o pipefail -c DEBIAN_FRONTEND=noninteractive apt-get -qq update &&   DEBIAN_FRONTEND=noninteractive apt-get -qq install --no-install-recommends -y     ca-certificates=20180409     curl=7.58.0-2ubuntu3.8     locales=2.27-3ubuntu1     bash=4.4.18-2ubuntu1.2     build-essential=12.4ubuntu1     diffutils=1:3.6-1     git=1:2.17.1-1ubuntu0.7     rsync=3.1.2-2.1ubuntu1     tar=1.29b-2ubuntu0.1     wget=1.19.4-1ubuntu2.2     bats=0.4.0-1.1     libperl-critic-perl=1.130-1     python3=3.6.7-1~18.04     python3-pip=9.0.1-2.3~ubuntu1.18.04.1     python3-setuptools=39.0.1-2     ruby=1:2.5.1     ruby-dev=1:2.5.1     shellcheck=0.4.6-1     &&     apt-get clean &&     rm -rf /var/lib/apt/lists/*' returned a non-zero code: 100
      [2020-06-24T21:42:12.472Z] ERROR: Docker failed to build yetus/hbase:023c6fe56b.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                ndimiduk Nick Dimiduk
                Reporter:
                ndimiduk Nick Dimiduk
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: