Uploaded image for project: 'HBase'
  1. HBase
  2. HBASE-24169

Drop hadoop 2 support for hbase 3.x

VotersStop watchingWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

Details

    • Umbrella
    • Status: Resolved
    • Blocker
    • Resolution: Fixed
    • None
    • 3.0.0-alpha-1
    • hadoop2, hadoop3, pom
    • None
    • Incompatible change
    • Hide
      The 'hadoop-2.0' profile has been removed. Now execute mvn command without '-Dhadoop.profile' will active the hadoop-3.0 profile.

      The hbase-hadoop2-compat module has been removed, the code have all been moved to hbase-hadoop-compat module.
      Show
      The 'hadoop-2.0' profile has been removed. Now execute mvn command without '-Dhadoop.profile' will active the hadoop-3.0 profile. The hbase-hadoop2-compat module has been removed, the code have all been moved to hbase-hadoop-compat module.

    Description

      As discussed several times on mailing list, I think it is time to do this.

      Attachments

        Issue Links

        Activity

          This comment will be Viewable by All Users Viewable by All Users
          Cancel

          People

            zhangduo Duo Zhang
            zhangduo Duo Zhang
            Votes:
            0 Vote for this issue
            Watchers:
            6 Stop watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Slack

                Issue deployment