Uploaded image for project: 'HBase'
  1. HBase
  2. HBASE-23905

move_namespaces_rsgroup is not moving namespace into desired rsgroup

    XMLWordPrintableJSON

Details

    • Bug
    • Status: Resolved
    • Major
    • Resolution: Invalid
    • 2.2.3
    • None
    • rsgroup
    • None

    Description

      When creating a namespace and specifying a rs group in hbase.rsgroup.name, the namespace gets associated with the mentioned rs group. However later, the namespace does not move to another rs group when using "move_namespace_rsgroup".

       

      Steps to reproduce the issue:

      1. create a rs group 'r1' and add a region server in it.
      2. create_namespace 'namespace',{METHOD => 'set', 'hbase.rsgroup.name' => 'r1'}
      3. describe_namespace 'namespace'
      4. move_namespaces_rsgroup 'default',['namespace']
      5. describe_namespace 'namespace'

      Before moving the namespace into another rs group, it will show rsgroup r1 but even after the step 4, it still shows same description of the namespace. This bug is not allowing me to remove a rs group because it keeps on telling "r1 cannot be deleted as namespace 'namespace' is still associated with the rs group 'r1' ".

       

       

       

       

      Attachments

        Activity

          People

            arshad.mohammad Mohammad Arshad
            Athem Saurav Mehta
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: