HBase
  1. HBase
  2. HBASE-235

Master and RegionServer web UIs show nonexistent regions after a DROP TABLE

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Trivial Trivial
    • Resolution: Cannot Reproduce
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      I dropped a table with 121 regions, ans read from the web UI. Afterwards, most of the regions went away, but 6 remained counted and listed in the web UI. select * from .META. shows no rows, so in reality the regions are gone. This inconsistency gives a poor sense of the consistency of HBase.

        Activity

        Bryan Duxbury created issue -
        Owen O'Malley made changes -
        Field Original Value New Value
        Key HADOOP-2743 HBASE-235
        Project Hadoop Core [ 12310240 ] Hadoop HBase [ 12310753 ]
        Bryan Duxbury made changes -
        Component/s hql [ 12312134 ]
        Edward J. Yoon made changes -
        Summary [hbase] Master and RegionServer web UIs show nonexistent regions after a DROP TABLE Master and RegionServer web UIs show nonexistent regions after a DROP TABLE
        Bryan Duxbury added a comment -

        Not a shell issue...

        Bryan Duxbury made changes -
        Component/s hql [ 12312134 ]
        Jim Kellerman added a comment -

        Please verify that this is still an issue.

        Jim Kellerman made changes -
        Assignee Izaak Rubin [ irubin ]
        Izaak Rubin added a comment -

        I'm not seeing any problem in the UI. I created a table with 7 regions (granted, not exactly 121 regions), and after I dropped it all those regions disappeared from the UI immediately. I would think that, especially since this issue was reported so long ago, it's probably become a non-issue. Although it's hard to say exactly how the UI would scale with 121 regions.

        stack added a comment -

        We haven't seen this in ages. Resolving. We can reopen if it shows up again later.

        stack made changes -
        Resolution Cannot Reproduce [ 5 ]
        Status Open [ 1 ] Resolved [ 5 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        272d 21h 13m 1 stack 29/Oct/08 18:20

          People

          • Assignee:
            Izaak Rubin
            Reporter:
            Bryan Duxbury
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development