Uploaded image for project: 'HBase'
  1. HBase
  2. HBASE-2233

Support both Hadoop 0.20, 0.21, and 0.22

    Details

    • Type: New Feature
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.92.0
    • Component/s: None
    • Labels:
      None
    • Hadoop Flags:
      Reviewed
    • Release Note:
      Hide
      HBase will run unadorned on hadoop 0.22 (HBase does not run on hadoop 0.21, not without forward port of recoverLease, HDFS-1948, and change to httpserver, HADOOP-7351)
      Show
      HBase will run unadorned on hadoop 0.22 (HBase does not run on hadoop 0.21, not without forward port of recoverLease, HDFS-1948 , and change to httpserver, HADOOP-7351 )

      Description

      Since Hadoop 0.21 isn't going to be well supported and that a lot of users may wish to stick on 0.20, the next HBase major release should support both 0.20 and 0.21.

      HDFS-265 support will be swapped for HDFS-200 if running on HDFS 0.20. A cluster without that patchset shouldn't be supported.

        Attachments

        1. 2233-v5.txt
          44 kB
          stack
        2. 2233-v4.txt
          42 kB
          stack
        3. 2233-v3.txt
          35 kB
          stack
        4. 2233-v2.txt
          29 kB
          stack
        5. pom.to.go.against.hadoop.trunk.txt
          4 kB
          stack
        6. 2233.txt
          7 kB
          stack

          Activity

            People

            • Assignee:
              stack stack
              Reporter:
              jdcryans Jean-Daniel Cryans
            • Votes:
              0 Vote for this issue
              Watchers:
              7 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: