Uploaded image for project: 'HBase'
  1. HBase
  2. HBASE-22130

[hbase-thirdparty] Upgrade thirdparty dependencies

    XMLWordPrintableJSON

    Details

    • Type: Task
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: thirdparty-2.2.0
    • Component/s: thirdparty
    • Labels:
      None
    • Release Note:
      Hide
      Made following upgrades:

      gson 2.8.1 -> 2.8.5
      guava 22.0 -> 27.1-jre
      pb 3.5.1 -> 3.7.0
      netty 4.1.17 -> 4.1.34
      commons-collections4 4.1 -> 4.3

      Updated apache parent pom from 18 to 21 and misc plugins.
      Show
      Made following upgrades: gson 2.8.1 -> 2.8.5 guava 22.0 -> 27.1-jre pb 3.5.1 -> 3.7.0 netty 4.1.17 -> 4.1.34 commons-collections4 4.1 -> 4.3 Updated apache parent pom from 18 to 21 and misc plugins.

      Description

      First guava has a CVE so we need to upgrade to at least 26.0, better to the newest 27.1.

      And we can also upgrade the other dependencies to the newest version at the same time.

        Attachments

          Activity

            People

            • Assignee:
              stack Michael Stack
              Reporter:
              zhangduo Duo Zhang
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: