Uploaded image for project: 'HBase'
  1. HBase
  2. HBASE-21528

hbase-connectors need scala dependency convergence

    XMLWordPrintableJSON

    Details

    • Type: Task
    • Status: Resolved
    • Priority: Minor
    • Resolution: Not A Problem
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: hbase-connectors
    • Labels:
      None

      Description

      this issue reappeared after migration of hbase-spark to hbase-connectors repo. Originally addressed in https://issues.apache.org/jira/browse/HBASE-20175 

      introducing scala-maven-plugin and adding a flag to honor compatible major scala version makes warning disappear.

       

      [WARNING] Expected all dependencies to require Scala version: 2.11.12
      [WARNING] org.apache.hbase.connectors.spark:hbase-spark:1.0.0-SNAPSHOT requires scala version: 2.11.12
      [WARNING] org.apache.spark:spark-streaming_2.11:2.4.0 requires scala version: 2.11.12
      [WARNING] org.apache.spark:spark-streaming_2.11:2.4.0 requires scala version: 2.11.12
      [WARNING] org.scala-lang:scala-reflect:2.11.12 requires scala version: 2.11.12
      [WARNING] org.apache.spark:spark-tags_2.11:2.4.0 requires scala version: 2.11.12
      [WARNING] com.twitter:chill_2.11:0.9.3 requires scala version: 2.11.12
      [WARNING] org.scala-lang.modules:scala-parser-combinators_2.11:1.1.0 requires scala version: 2.11.12
      [WARNING] org.json4s:json4s-core_2.11:3.2.11 requires scala version: 2.11.0
      [WARNING] Multiple versions of scala libraries detected!
      [WARNING] warning: there were 17 deprecation warnings; re-run with -deprecation for details
      [WARNING] one warning found
      [WARNING] Expected all dependencies to require Scala version: 2.11.12
      [WARNING] org.apache.hbase.connectors.spark:hbase-spark:1.0.0-SNAPSHOT requires scala version: 2.11.12
      [WARNING] org.apache.spark:spark-streaming_2.11:2.4.0 requires scala version: 2.11.12
      [WARNING] org.apache.spark:spark-streaming_2.11:2.4.0 requires scala version: 2.11.12
      [WARNING] org.scala-lang:scala-reflect:2.11.12 requires scala version: 2.11.12
      [WARNING] org.apache.spark:spark-tags_2.11:2.4.0 requires scala version: 2.11.12
      [WARNING] com.twitter:chill_2.11:0.9.3 requires scala version: 2.11.12
      [WARNING] org.scala-lang.modules:scala-parser-combinators_2.11:1.1.0 requires scala version: 2.11.12
      [WARNING] org.json4s:json4s-core_2.11:3.2.11 requires scala version: 2.11.0
      [WARNING] Multiple versions of scala libraries detected!

        Attachments

        1. HBASE-21528.v01.patch
          1 kB
          Artem Ervits
        2. HBASE-21528.v02.patch
          1 kB
          Artem Ervits

          Activity

            People

            • Assignee:
              dbist13 Artem Ervits
              Reporter:
              dbist13 Artem Ervits
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: