Uploaded image for project: 'HBase'
  1. HBase
  2. HBASE-21240

Use the "guava beta checker" plugin for error-prone to keep us off of @Beta stuff

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Open
    • Priority: Minor
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: dependencies
    • Labels:
      None

      Description

      The Guava folks publish an Error Prone plugin to call attention to when stuff that's annotated with @Beta gets used. As background, those things are a no-no because the project gives no promises about deprecating before removal.

      plugin:

      https://github.com/google/guava-beta-checker

      We'll probably have to do some hijinks due to guava being in hbase-third-party?

        Attachments

          Activity

            People

            • Assignee:
              mdrob Mike Drob
              Reporter:
              busbey Sean Busbey
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated: