Uploaded image for project: 'HBase'
  1. HBase
  2. HBASE-19076

Ensure findbugs jsr305 jar isn't present in hbase-error-prone module

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 3.0.0
    • Fix Version/s: None
    • Component/s: dependencies
    • Labels:
      None

      Description

      After HBASE-16321 ensure findbugs jsr305 jar isn't present, we have failures with the hbase-error-prone module.

      [INFO] --- maven-enforcer-plugin:3.0.0-M1:enforce (min-maven-min-java-banned-xerces) @ hbase-error-prone ---
      [INFO] 
      [INFO] --- maven-enforcer-plugin:3.0.0-M1:enforce (banned-jsr305) @ hbase-error-prone ---
      [WARNING] Rule 0: org.apache.maven.plugins.enforcer.BannedDependencies failed with message:
      We don't allow the JSR305 jar from the Findbugs project, see HBASE-16321.
      Found Banned Dependency: com.google.code.findbugs:jsr305:jar:1.3.9
      Use 'mvn dependency:tree' to locate the source of the banned dependencies.
      

        Attachments

        1. HBASE-19076.patch
          1 kB
          Qilin Cao

          Activity

            People

            • Assignee:
              Qilin Cao Qilin Cao
              Reporter:
              Qilin Cao Qilin Cao
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: