Uploaded image for project: 'HBase'
  1. HBase
  2. HBASE-16403

Upgrade guava version to the lastest one(19.0)

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Major
    • Resolution: Duplicate
    • Affects Version/s: 1.1.4
    • Fix Version/s: None
    • Component/s: API, Client
    • Labels:
      None

      Description

      HBase client use the guava version 12.0.1, while elasticsearch sdk use the version 18+. It makes conflict, cause the constructor of StopWatch class is not public now.

      We have to choose the es rest api to resolve the conflict. Why not try to upgrade our dependency versions?

      thx.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                onecoder lihongzhe
              • Votes:
                0 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: