HBase
  1. HBase
  2. HBASE-1473

Detach UI from servers or "Where is my cluster summary when 10 masters and current one died"?

    Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      UI can run distinct from master. Can ask zk who master is then ask master questions to display data (JMX?). Could probably do same for the regionserver UIs.

        Issue Links

          Activity

          stack created issue -
          stack added a comment -

          We would lose being able to thread dump and read logs via UI. Maybe thats no biggy?

          stack made changes -
          Field Original Value New Value
          Link This issue is related to HBASE-9404 [ HBASE-9404 ]
          stack added a comment -

          Resolving as duplicate of HBASE-9404. It has more detail.

          stack made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Resolution Duplicate [ 3 ]

            People

            • Assignee:
              Unassigned
              Reporter:
              stack
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development