Uploaded image for project: 'HBase'
  1. HBase
  2. HBASE-13344

Add enforcer rule that matches our JDK support statement

    XMLWordPrintableJSON

Details

    Description

      The ref guide gives a list of JDKs that we expect our hbase versions to work with at runtime.

      Let's add in the extra-enforcer-rules mojo and start using the bytecode version rule to make sure that the result of our builds on a given branch won't fail out because of a misconfigured target jdk version (or a dependency that targets a later jdk).

      Attachments

        1. HBASE-13344-master_addendum_v1.patch
          2 kB
          Matt Warhaftig
        2. HBASE-13344-master_v2.patch
          2 kB
          Matt Warhaftig
        3. HBASE-13344-master.patch
          2 kB
          Matt Warhaftig

        Issue Links

          Activity

            People

              mwarhaftig Matt Warhaftig
              busbey Sean Busbey
              Votes:
              0 Vote for this issue
              Watchers:
              9 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: