Uploaded image for project: 'HBase'
  1. HBase
  2. HBASE-11339 HBase MOB
  3. HBASE-12646

SnapshotInfo tool does not find mob data in snapshots

Log workAgile BoardRank to TopRank to BottomAttach filesAttach ScreenshotBulk Copy AttachmentsBulk Move AttachmentsVotersWatch issueWatchersConvert to IssueMoveLinkCloneLabelsUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

Details

    • Sub-task
    • Status: Closed
    • Major
    • Resolution: Fixed
    • hbase-11339
    • hbase-11339, 2.0.0
    • mob, snapshots
    • None
    • Reviewed

    Description

      After taking a snapshot against a table with mob file data, the SnapshotInfo tool is not able to find the mob files even though they are present in the proper place. (<hbase>/mobdir/data/dfault/<table>/<region>/....)

      Here's an example command line execution:

      [jon@a1210 hbase]$ bin/hbase org.apache.hadoop.hbase.snapshot.SnapshotInfo -snapshot test -files
      ....
             - IntegrationTestIngestWithMOB/e9b5d936e7f55a4f1c3246a8d5ce53c2/test_cf/e75380c6db50db845dbdee48ab49381420141205f87d1b47b0f446c7acb3fa0656fa8a57 (NOT FOUND)
      
      **************************************************************
      BAD SNAPSHOT: 145 hfile(s) and 0 log(s) missing.
                    0 hfile(s) corrupted.
      **************************************************************
      54 HFiles (54 in archive), total size 973.6 M (0.00% 0 shared with the source table)
      0 Logs, total size 0
      

      The missing files are actually present, it is likely that the snapshot tool doesn't know to look in the mob dir.

      Attachments

        Activity

          This comment will be Viewable by All Users Viewable by All Users
          Cancel

          People

            jmhsieh Jonathan Hsieh Assign to me
            jmhsieh Jonathan Hsieh
            Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Slack

                Issue deployment