Uploaded image for project: 'HBase'
  1. HBase
  2. HBASE-12533

staging directories are not deleted after secure bulk load

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 0.98.6
    • Fix Version/s: 2.0.0, 0.98.9, 0.99.2
    • Component/s: regionserver
    • Labels:
      None
    • Environment:

      CDH5.2 + Kerberos

    • Hadoop Flags:
      Reviewed

      Description

      We using secure bulk load heavily in our environment. And it was working with no problem during some time. But last week I found that clients hangs while calling doBulkLoad

      After some investigation I found that HDFS keeps more than 1,000,000 directories in /tmp/hbase-staging directory.

      When directory's content was purged the load process runs successfully.

      According the hbase book

      HBase manages creation and deletion of this directory.
      
      1. HBASE-12533.patch
        6 kB
        Jeffrey Zhong
      2. HBASE-12533-v2.patch
        8 kB
        Jeffrey Zhong

        Issue Links

          Activity

          jeffreyz Jeffrey Zhong added a comment -

          Andrejs Dubovskis What kind of folders are left in the staging folder? Could you show some examples? I'm assuming you saw issue that bulkload runs successfully while it still leave some folders in staging folder after the bulkload.

          yuzhihong@gmail.com Ted Yu added a comment -

          cleanupBulkLoad() is called by LoadIncrementalHFiles :

                if(bulkToken != null) {
                  new SecureBulkLoadClient(table).cleanupBulkLoad(bulkToken);
                }
          

          I wonder if SecureBulkLoadEndpoint should maintain a map of bulkToken and the time bulkToken is generated.
          SecureBulkLoadEndpoint can use this data structure to report bulkTokens which haven't been cleaned after configured period of time.

          dubislv Andrejs Dubovskis added a comment -

          Jeffrey Zhong Few samples of folder names

          drwxrwxrwx   - hbase supergroup          0 2014-11-18 06:32 /tmp/hbase-staging/catalyst__prod_cases1031__11v1ukqbar2ifiseq1godtfo5roglkd0eu1dslnvolt6ntq3oiq14o7i8ecijkfo
          drwxrwxrwx   - hbase supergroup          0 2014-11-17 23:32 /tmp/hbase-staging/catalyst__prod_cases1031__120n26ihe744fol9ci6t2cfi5fj6ubliofha9do78sgfc37m74rndeosk9qptof6
          

          Folder name constructed from

          1. username (catalyst)
          2. namespace (prod)
          3. table name (cases1031)
          4. randomly generated string
          jeffreyz Jeffrey Zhong added a comment -

          From the pasted left folder names and they're root staging folders used by bulk load. In the code, I run a small test against the 0.98 code and seems they're cleared after a bulkload.

          jeffreyz Jeffrey Zhong added a comment -

          I think I found the root cause of the issue, which I think it's a serious one. Below is the culprit:

            public String prepareBulkLoad(final TableName tableName) throws IOException {
              try {
                return
                  table.coprocessorService(SecureBulkLoadProtos.SecureBulkLoadService.class,
                    EMPTY_START_ROW,
                    LAST_ROW,
           ...
          

          The prepareBulkLoad is fired up to hit all data regions so it will create same number of staging folders as the number of regions of the bulkloaded table while we only use the first one.

          That's why you can see many staging folders are left.

          There are couple of bugs in the SecureBulkLoadEndpoint#cleanupBulkLoad. 1) fire same request to all data regions 2) It tries to firstly create an already existing folder and then delete it. Too many unnecessary NN operations.

          jeffreyz Jeffrey Zhong added a comment -

          This issue also cause bulkload slow because it fire unnecessary RPC requests to hit all data regions to create/delete staging folders.

          hadoopqa Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12682593/HBASE-12533.patch
          against master branch at commit b6dd9b441fb279bbd7b6c48d809166b2b0235514.
          ATTACHMENT ID: 12682593

          +1 @author. The patch does not contain any @author tags.

          -1 tests included. The patch doesn't appear to include any new or modified tests.
          Please justify why no new tests are needed for this patch.
          Also please list what manual steps were performed to verify this patch.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          -1 javadoc. The javadoc tool appears to have generated 1 warning messages.

          +1 checkstyle. The applied patch does not increase the total number of checkstyle errors

          +1 findbugs. The patch does not introduce any new Findbugs (version 2.0.3) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          +1 lineLengths. The patch does not introduce lines longer than 100

          +1 site. The mvn site goal succeeds with this patch.

          +1 core tests. The patch passed unit tests in .

          Test results: https://builds.apache.org/job/PreCommit-HBASE-Build/11760//testReport/
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/11760//artifact/patchprocess/newPatchFindbugsWarningshbase-rest.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/11760//artifact/patchprocess/newPatchFindbugsWarningshbase-common.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/11760//artifact/patchprocess/newPatchFindbugsWarningshbase-client.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/11760//artifact/patchprocess/newPatchFindbugsWarningshbase-annotations.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/11760//artifact/patchprocess/newPatchFindbugsWarningshbase-hadoop-compat.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/11760//artifact/patchprocess/newPatchFindbugsWarningshbase-server.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/11760//artifact/patchprocess/newPatchFindbugsWarningshbase-prefix-tree.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/11760//artifact/patchprocess/newPatchFindbugsWarningshbase-protocol.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/11760//artifact/patchprocess/newPatchFindbugsWarningshbase-thrift.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/11760//artifact/patchprocess/newPatchFindbugsWarningshbase-examples.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/11760//artifact/patchprocess/newPatchFindbugsWarningshbase-hadoop2-compat.html
          Checkstyle Errors: https://builds.apache.org/job/PreCommit-HBASE-Build/11760//artifact/patchprocess/checkstyle-aggregate.html

          Javadoc warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/11760//artifact/patchprocess/patchJavadocWarnings.txt
          Console output: https://builds.apache.org/job/PreCommit-HBASE-Build/11760//console

          This message is automatically generated.

          enis Enis Soztutar added a comment -

          So, in the patch instead of calling the bulk load endpoint for prepare and cleanup for every region, we are just calling them for only the first region in the table if I understand the patch correctly. It seems strange that we are relying on the client to send the clean up request rather than keeping lease and do the server side clean up, since if the client goes away, the staging dir will still be left there forever. We should fix that in another issue perhaps.

          Can you add a comment when we are calling the coprocessors to say that we are only calling the first region. Other than that +1.

          yuzhihong@gmail.com Ted Yu added a comment -

          Created HBASE-12547 for server side clean up of bulk load staging directories.

          jeffreyz Jeffrey Zhong added a comment -

          Can you add a comment when we are calling the coprocessors to say that we are only calling the first region

          Yes, we're use the first region to call the prepareBulkLoad once.

          jeffreyz Jeffrey Zhong added a comment -

          Andrejs Dubovskis Is that possible for you to try to patch to see if the issue is addressed? The patch should be able to apply to 0.98 code base as well. Thanks.

          jeffreyz Jeffrey Zhong added a comment -

          I tested the patch in a secure env and verified the fix solves the issue. In the v2 patch, I amended the existing test case by adding a check to verify we don't left staging folders behind.

          hadoopqa Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12683912/HBASE-12533-v2.patch
          against master branch at commit 02963b202ae3c05a6326a194da1f0e23df9aeca0.
          ATTACHMENT ID: 12683912

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 3 new or modified tests.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 checkstyle. The applied patch does not increase the total number of checkstyle errors

          +1 findbugs. The patch does not introduce any new Findbugs (version 2.0.3) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          +1 lineLengths. The patch does not introduce lines longer than 100

          +1 site. The mvn site goal succeeds with this patch.

          -1 core tests. The patch failed these unit tests:
          org.apache.hadoop.hbase.client.TestFromClientSide
          org.apache.hadoop.hbase.client.TestFromClientSideWithCoprocessor

          Test results: https://builds.apache.org/job/PreCommit-HBASE-Build/11844//testReport/
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/11844//artifact/patchprocess/newPatchFindbugsWarningshbase-annotations.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/11844//artifact/patchprocess/newPatchFindbugsWarningshbase-hadoop2-compat.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/11844//artifact/patchprocess/newPatchFindbugsWarningshbase-common.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/11844//artifact/patchprocess/newPatchFindbugsWarningshbase-hadoop-compat.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/11844//artifact/patchprocess/newPatchFindbugsWarningshbase-protocol.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/11844//artifact/patchprocess/newPatchFindbugsWarningshbase-prefix-tree.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/11844//artifact/patchprocess/newPatchFindbugsWarningshbase-client.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/11844//artifact/patchprocess/newPatchFindbugsWarningshbase-examples.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/11844//artifact/patchprocess/newPatchFindbugsWarningshbase-thrift.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/11844//artifact/patchprocess/newPatchFindbugsWarningshbase-rest.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/11844//artifact/patchprocess/newPatchFindbugsWarningshbase-server.html
          Checkstyle Errors: https://builds.apache.org/job/PreCommit-HBASE-Build/11844//artifact/patchprocess/checkstyle-aggregate.html

          Console output: https://builds.apache.org/job/PreCommit-HBASE-Build/11844//console

          This message is automatically generated.

          stack stack added a comment -

          Failures are not from this patch and should be fixed now.

          jeffreyz Jeffrey Zhong added a comment -

          Thanks for the review/comments! I've integrated the fix into 0.98,0.99 & master branches.

          hudson Hudson added a comment -

          FAILURE: Integrated in HBase-TRUNK #5830 (See https://builds.apache.org/job/HBase-TRUNK/5830/)
          HBASE-12533: staging directories are not deleted after secure bulk load (jeffreyz: rev f0d95e7f11403d67b4fc3f1fd4ef048047b6842a)

          • hbase-client/src/main/java/org/apache/hadoop/hbase/client/coprocessor/SecureBulkLoadClient.java
          • hbase-server/src/test/java/org/apache/hadoop/hbase/mapreduce/TestLoadIncrementalHFiles.java
          • hbase-server/src/main/java/org/apache/hadoop/hbase/security/access/SecureBulkLoadEndpoint.java
          hudson Hudson added a comment -

          SUCCESS: Integrated in HBase-1.0 #512 (See https://builds.apache.org/job/HBase-1.0/512/)
          HBASE-12533: staging directories are not deleted after secure bulk load (jeffreyz: rev 643de2df041a2270798398906343b558ee5e2a6f)

          • hbase-server/src/main/java/org/apache/hadoop/hbase/security/access/SecureBulkLoadEndpoint.java
          • hbase-server/src/test/java/org/apache/hadoop/hbase/mapreduce/TestLoadIncrementalHFiles.java
          • hbase-client/src/main/java/org/apache/hadoop/hbase/client/coprocessor/SecureBulkLoadClient.java
          hudson Hudson added a comment -

          FAILURE: Integrated in HBase-0.98 #704 (See https://builds.apache.org/job/HBase-0.98/704/)
          HBASE-12533: staging directories are not deleted after secure bulk load (jeffreyz: rev 9b9595d556f5ce0268fb6921b033e503726183a8)

          • hbase-server/src/main/java/org/apache/hadoop/hbase/security/access/SecureBulkLoadEndpoint.java
          • hbase-server/src/test/java/org/apache/hadoop/hbase/mapreduce/TestLoadIncrementalHFiles.java
          • hbase-client/src/main/java/org/apache/hadoop/hbase/client/coprocessor/SecureBulkLoadClient.java
          hudson Hudson added a comment -

          FAILURE: Integrated in HBase-0.98-on-Hadoop-1.1 #671 (See https://builds.apache.org/job/HBase-0.98-on-Hadoop-1.1/671/)
          HBASE-12533: staging directories are not deleted after secure bulk load (jeffreyz: rev 9b9595d556f5ce0268fb6921b033e503726183a8)

          • hbase-client/src/main/java/org/apache/hadoop/hbase/client/coprocessor/SecureBulkLoadClient.java
          • hbase-server/src/test/java/org/apache/hadoop/hbase/mapreduce/TestLoadIncrementalHFiles.java
          • hbase-server/src/main/java/org/apache/hadoop/hbase/security/access/SecureBulkLoadEndpoint.java
          enis Enis Soztutar added a comment -

          Closing this issue after 0.99.2 release.


            People

            • Assignee:
              jeffreyz Jeffrey Zhong
              Reporter:
              dubislv Andrejs Dubovskis
            • Votes:
              0 Vote for this issue
              Watchers:
              13 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development