HBase
  1. HBase
  2. HBASE-11673

TestIOFencing#testFencingAroundCompactionAfterWALSync fails

    Details

    • Type: Test Test
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.0.0
    • Component/s: None
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      got several test failure on the latest build:

      [tianq@bdvm101 surefire-reports]$ ls -1t|grep "Tests run" * |grep "<<< FAILURE"
      org.apache.hadoop.hbase.client.TestReplicasClient.txt:Tests run: 1, Failures: 0, Errors: 1, Skipped: 0, Time elapsed: 38.706 sec <<< FAILURE!
      org.apache.hadoop.hbase.master.TestMasterOperationsForRegionReplicas.txt:Tests run: 2, Failures: 1, Errors: 0, Skipped: 0, Time elapsed: 30.669 sec <<< FAILURE!
      org.apache.hadoop.hbase.regionserver.TestRegionReplicas.txt:Tests run: 1, Failures: 0, Errors: 1, Skipped: 0, Time elapsed: 39.113 sec <<< FAILURE!
      org.apache.hadoop.hbase.TestIOFencing.txt:Tests run: 2, Failures: 1, Errors: 0, Skipped: 0, Time elapsed: 177.071 sec <<< FAILURE!

      the first one:

      <failure message="Timed out waiting for the region to flush" type="java.lang.AssertionError">java.lang.AssertionError: Timed out waiting for the region to flush
      >-at org.junit.Assert.fail(Assert.java:88)
      >-at org.junit.Assert.assertTrue(Assert.java:41)
      >-at org.apache.hadoop.hbase.TestIOFencing.doTest(TestIOFencing.java:291)
      >-at org.apache.hadoop.hbase.TestIOFencing.testFencingAroundCompactionAfterWALSync(TestIOFencing.java:236)
      >-at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      >-at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
      >-at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      >-at java.lang.reflect.Method.invoke(Method.java:606)

        Activity

        Qiang Tian added a comment -

        I can repro consistently. but the hadoop QA run looks good....

        Sergey Soldatov added a comment -

        changed hbase.hstore.compaction.min to 1 from the default 3. This problem was introduced with HBASE-11120

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12659983/HBASE_11673-v1.patch
        against trunk revision .
        ATTACHMENT ID: 12659983

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 3 new or modified tests.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 findbugs. The patch does not introduce any new Findbugs (version 2.0.3) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        +1 lineLengths. The patch does not introduce lines longer than 100

        +1 site. The mvn site goal succeeds with this patch.

        -1 core tests. The patch failed these unit tests:
        org.apache.hadoop.hbase.regionserver.TestEndToEndSplitTransaction
        org.apache.hadoop.hbase.regionserver.TestRegionReplicas
        org.apache.hadoop.hbase.client.TestReplicasClient
        org.apache.hadoop.hbase.master.TestRestartCluster
        org.apache.hadoop.hbase.TestRegionRebalancing

        Test results: https://builds.apache.org/job/PreCommit-HBASE-Build/10307//testReport/
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/10307//artifact/patchprocess/newPatchFindbugsWarningshbase-hadoop2-compat.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/10307//artifact/patchprocess/newPatchFindbugsWarningshbase-prefix-tree.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/10307//artifact/patchprocess/newPatchFindbugsWarningshbase-common.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/10307//artifact/patchprocess/newPatchFindbugsWarningshbase-thrift.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/10307//artifact/patchprocess/newPatchFindbugsWarningshbase-examples.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/10307//artifact/patchprocess/newPatchFindbugsWarningshbase-client.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/10307//artifact/patchprocess/newPatchFindbugsWarningshbase-hadoop-compat.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/10307//artifact/patchprocess/newPatchFindbugsWarningshbase-server.html
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/10307//artifact/patchprocess/newPatchFindbugsWarningshbase-protocol.html
        Console output: https://builds.apache.org/job/PreCommit-HBASE-Build/10307//console

        This message is automatically generated.

        Ted Yu added a comment -

        Thanks for the patch, Sergey

        Integrated to master.

        Hudson added a comment -

        FAILURE: Integrated in HBase-TRUNK #5373 (See https://builds.apache.org/job/HBase-TRUNK/5373/)
        HBASE-11673 TestIOFencing#testFencingAroundCompactionAfterWALSync fails(Sergey Soldatov) (tedyu: rev c9d0feb2846668576ab824478177ee15b9be81e2)

        • hbase-server/src/test/java/org/apache/hadoop/hbase/TestIOFencing.java
        Ted Yu added a comment -

        The test fails in HBase-TRUNK build #5375

        Mind taking a look ?

        Mikhail Antonov added a comment -

        I don't see this test in the list of failed tests on the referenced build. Following tests failed:

        Test Result (6 failures / +1)
        org.apache.hadoop.hbase.ipc.TestIPC.testRTEDuringConnectionSetup
        org.apache.hadoop.hbase.ipc.TestIPC.testRpcScheduler
        org.apache.hadoop.hbase.ipc.TestIPC.testCompressCellBlock
        org.apache.hadoop.hbase.ipc.TestIPC.testNoCodec
        org.apache.hadoop.hbase.master.TestClockSkewDetection.testClockSkewDetection
        org.apache.hadoop.hbase.procedure.TestProcedureManager.org.apache.hadoop.hbase.procedure.TestProcedureManager

        Ted Yu added a comment -

        test output from Jenkins.

        Mikhail Antonov added a comment -

        Ted Yu

        looking at https://builds.apache.org/view/All/job/HBase-TRUNK/5381/console results, I'm seeing this test passed:

        Tests run: 4, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 27.378 sec
        Running org.apache.hadoop.hbase.TestMultiVersions
        Tests run: 3, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 13.35 sec
        Running org.apache.hadoop.hbase.TestIOFencing
        Tests run: 2, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 195.001 sec
        Running org.apache.hadoop.hbase.mapreduce.TestLoadIncrementalHFiles
        Tests run: 12, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 35.649 sec

        Do you think this issue could be resolved now?

        Ted Yu added a comment -

        Do you have a chance to check the attached Jenkins build output to see what caused the test to fail ?

        Sergey Soldatov added a comment -

        I'm unable to reproduce it even on that commit and from log file it's not clear what was wrong.

        Mikhail Antonov added a comment -

        Ted Yu, Qiang Tian, Sergey Soldatov - I've looked thru last 4 builds of hbase-trunk started by hadoop-qa, in all of them this test has passed successfully (in several of them, though, TestRegionRebalancing has failed, but that's another story). So unless someone has a sequence of steps to reliably reproduce the failure, I'd say we can resolve this jira (and re-open later, if we have more details about the failure).
        What do you think? Qiang Tian does this test pass for you now?

        Ted Yu added a comment -

        Sounds good.

        Resolving again.

        Qiang Tian added a comment -

        Hi Mikhail Antonov, I just ran it, it passed.
        thanks.


          People

          • Assignee:
            Sergey Soldatov
            Reporter:
            Qiang Tian
          • Votes:
            0 Vote for this issue
            Watchers:
            7 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development