HBase
  1. HBase
  2. HBASE-11575

Pseudo distributed mode does not work as documented

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.99.0, 2.0.0
    • Component/s: None
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      After master-RS colocation, now the pseudo dist-mode does not work as documented since you cannot start a region server in the same port 16020.

      I think we can either select a random port (and info port) for the master's region server, or document how to do a pseudo-distributed setup in the book.

      Jimmy Xiang wdyt?

        Issue Links

          Activity

          Jimmy Xiang added a comment -

          Probably it's better to use a random port. Let me take a look.

          Jimmy Xiang added a comment -

          Looked into it and attached a patch that fixed some documentation mismatches, changed the pseudo distributed mode setting a little so that we just start one instance. Additional regionservers can be started with the local regionserver sh script.

          Enis Soztutar added a comment -

          So we are not doing the random port approach? It should be ok.

          With hbase.master.wait.on.regionservers.mintostart set to 1, master should be able to finish initialization. Can user regions be opened in this mode from the RS inside msater?

          Jimmy Xiang added a comment -

          We can do random port for web UI, but not for IPC port. Yes, user regions can be opened in the RS inside the master. If additional regionservers are started, balancer can move user regions out of the master.

          Jerry He added a comment -

          We probably should avoid random port.
          See HBASE-10289.

          Enis Soztutar added a comment -

          1 for branch-1 if you have tested the script changes. Thanks Jimmy for nailing this.

          Jimmy Xiang added a comment -

          Yes, the patch worked for me. Pseudo distributed mode is fixed. Thanks for reporting the issue and reviewing the patch. Integrated in branch 1 and master.

          Hudson added a comment -

          SUCCESS: Integrated in HBase-TRUNK #5340 (See https://builds.apache.org/job/HBase-TRUNK/5340/)
          HBASE-11575 Pseudo distributed mode does not work as documented (jxiang: rev cc61cc308168af407a2f21851e9932292af8ca77)

          • conf/regionservers
          • bin/hbase-config.sh
          • bin/local-master-backup.sh
          • bin/local-regionservers.sh
          • src/main/docbkx/getting_started.xml
          Hudson added a comment -

          SUCCESS: Integrated in HBase-1.0 #68 (See https://builds.apache.org/job/HBase-1.0/68/)
          HBASE-11575 Pseudo distributed mode does not work as documented (jxiang: rev 147a3521f94f82c3a189a4ace2f7232c48b1ad5d)

          • bin/local-master-backup.sh
          • bin/local-regionservers.sh
          • bin/hbase-config.sh
          • conf/regionservers
          • src/main/docbkx/getting_started.xml
          stack added a comment -

          hbase.master.wait.on.regionservers.mintostart should be set to 1.

          Does it have to be this way Jimmy? This is in branch-1 too? That'd be a pain for users. Would be ok for master I'd say.

          Jimmy Xiang added a comment -

          Unfortunately, it is in branch-1 too. The problem is that master uses the same RPC port as a region server now. Not sure how to handle this better.

          Jimmy Xiang added a comment -

          Release note is removed since we are going to change the code so that additional config is not needed. See HBASE-11604.

          Enis Soztutar added a comment -

          Closing this issue after 0.99.0 release.


            People

            • Assignee:
              Jimmy Xiang
              Reporter:
              Enis Soztutar
            • Votes:
              0 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development