Uploaded image for project: 'HBase'
  1. HBase
  2. HBASE-11552

Read/Write requests count metric value is too short

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Duplicate
    • Affects Version/s: 0.94.21
    • Fix Version/s: 0.94.22
    • Component/s: metrics
    • Labels:
      None

      Description

      I am using readRequestsCount and writeRequestsCount counters to plot HBase activity in opentsdb and noticed that they are exported as int value although the underlying counter backed by a long counter.
      Metric should be a long as well.

        Activity

        hadoopqa Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12656826/HBASE-11552_v1.diff
        against trunk revision .
        ATTACHMENT ID: 12656826

        +1 @author. The patch does not contain any @author tags.

        -1 tests included. The patch doesn't appear to include any new or modified tests.
        Please justify why no new tests are needed for this patch.
        Also please list what manual steps were performed to verify this patch.

        -1 patch. The patch command could not apply the patch.

        Console output: https://builds.apache.org/job/PreCommit-HBASE-Build/10131//console

        This message is automatically generated.

        amuraru Adrian Muraru added a comment -

        Renamed patch file to include 0.94 branch only

        hadoopqa Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12656827/HBASE-11552_0.94_v1.diff
        against trunk revision .
        ATTACHMENT ID: 12656827

        +1 @author. The patch does not contain any @author tags.

        -1 tests included. The patch doesn't appear to include any new or modified tests.
        Please justify why no new tests are needed for this patch.
        Also please list what manual steps were performed to verify this patch.

        -1 patch. The patch command could not apply the patch.

        Console output: https://builds.apache.org/job/PreCommit-HBASE-Build/10132//console

        This message is automatically generated.

        jmspaggi Jean-Marc Spaggiari added a comment -

        Hi Adrian Muraru

        Is Counter already part of the HBase dependencies? Or are you adding a new dependency? I can not find it on current version.

        ishanc Ishan Chhabra added a comment -
        jmspaggi Jean-Marc Spaggiari added a comment -

        I agree. So let's close as duplicate of 10645.
        Adrian Muraru feel free to comment on 10645.


          People

          • Assignee:
            Unassigned
            Reporter:
            amuraru Adrian Muraru
          • Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development