Uploaded image for project: 'HBase'
  1. HBase
  2. HBASE-11075

TestVisibilityLabelsWithDistributedLogReplay is failing in Precommit builds frequently

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      Latest precommit builds I could see TestVisibilityLabelsWithDistributedLogReplay failing frequently. Need to identify the root cause and fix it.

        Activity

        Hide
        ram_krish ramkrishna.s.vasudevan added a comment -

        Test results: https://builds.apache.org/job/PreCommit-HBASE-Build/9399//testReport/
        Test results: https://builds.apache.org/job/PreCommit-HBASE-Build/9377//testReport/

        These report cannot be opened now but these are instances where it failed. See HBASE-11053 and HBASE-11054.

        Show
        ram_krish ramkrishna.s.vasudevan added a comment - Test results: https://builds.apache.org/job/PreCommit-HBASE-Build/9399//testReport/ Test results: https://builds.apache.org/job/PreCommit-HBASE-Build/9377//testReport/ These report cannot be opened now but these are instances where it failed. See HBASE-11053 and HBASE-11054 .
        Hide
        apurtell Andrew Purtell added a comment -

        Firing up the looping test rig. Will report back if I see this there.

        Show
        apurtell Andrew Purtell added a comment - Firing up the looping test rig. Will report back if I see this there.
        Hide
        ram_krish ramkrishna.s.vasudevan added a comment -

        Ran more than 50 times in a loop. The test did not fail for me.

        Show
        ram_krish ramkrishna.s.vasudevan added a comment - Ran more than 50 times in a loop. The test did not fail for me.
        Hide
        ram_krish ramkrishna.s.vasudevan added a comment -

        While debugging some cases with deletes, I found in a testcase (without visibility in it) that some times SCan happens even before the log replay is done. Is it only a test case issue or it happens only in Unit tests or even may be the debugging makes the split log to happen very slowly? But may be this failure is similar to that. Let me check it more closely.

        Show
        ram_krish ramkrishna.s.vasudevan added a comment - While debugging some cases with deletes, I found in a testcase (without visibility in it) that some times SCan happens even before the log replay is done. Is it only a test case issue or it happens only in Unit tests or even may be the debugging makes the split log to happen very slowly? But may be this failure is similar to that. Let me check it more closely.

          People

          • Assignee:
            ram_krish ramkrishna.s.vasudevan
            Reporter:
            ram_krish ramkrishna.s.vasudevan
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development