HBase
  1. HBase
  2. HBASE-10542

ConcurrentModificationException in TestHTraceHooks

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      I got this in one of my test runs:

      <error type="java.util.ConcurrentModificationException">java.util.ConcurrentModificationException
              at java.util.HashMap$HashIterator.nextEntry(HashMap.java:894)
              at java.util.HashMap$KeyIterator.next(HashMap.java:928)
              at org.cloudera.htrace.TraceTree.&lt;init&gt;(TraceTree.java:48)
              at org.apache.hadoop.hbase.trace.TestHTraceHooks.testTraceCreateTable(TestHTraceHooks.java:118)
              at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
              at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
              at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
              at java.lang.reflect.Method.invoke(Method.java:601)
              at org.junit.runners.model.FrameworkMethod$1.runReflectiveCall(FrameworkMethod.java:47)
              at org.junit.internal.runners.model.ReflectiveCallable.run(ReflectiveCallable.java:12)
              at org.junit.runners.model.FrameworkMethod.invokeExplosively(FrameworkMethod.java:44)
              at org.junit.internal.runners.statements.InvokeMethod.evaluate(InvokeMethod.java:17)
      

      It looks like TraceTree ctor, clones the spans collection, but iterates over the original argument, rather than cloned.

      I don't know enough of HTrace to fix it, so just reporting it here. Elliott Clark FYI.

        Activity

        Enis Soztutar created issue -
        Enis Soztutar added a comment -

        We did not see this recently.

        Enis Soztutar made changes -
        Field Original Value New Value
        Resolution Cannot Reproduce [ 5 ]
        Fix Version/s 0.99.0 [ 12325675 ]
        Status Open [ 1 ] Resolved [ 5 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        206d 9h 2m 1 Enis Soztutar 09/Sep/14 06:19

          People

          • Assignee:
            Unassigned
            Reporter:
            Enis Soztutar
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development