Uploaded image for project: 'HBase'
  1. HBase
  2. HBASE-10375

hbase-default.xml hbase.status.multicast.address.port does not match code

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 0.98.0, 0.99.0, 0.96.1.1
    • Fix Version/s: 0.98.0, 0.96.2, 0.99.0
    • Component/s: None
    • Labels:
      None
    • Hadoop Flags:
      Incompatible change, Reviewed

      Description

      In hbase-default.xml

      +  <property>
      +    <name>hbase.status.multicast.address.port</name>
      +    <value>6100</value>
      +    <description>
      +      Multicast port to use for the status publication by multicast.
      +    </description>
      +  </property>
      

      In HConstants it was 60100.

        public static final String STATUS_MULTICAST_PORT = "hbase.status.multicast.port";
        public static final int DEFAULT_STATUS_MULTICAST_PORT = 16100;
      

      (it was 60100 in the code for 0.96 and 0.98.)

      I lean towards going with the code as opposed to the config file.

        Attachments

        1. 10375.v2.96-98.patch
          1 kB
          Nicolas Liochon
        2. 10375.v2.trunk.patch
          1 kB
          Nicolas Liochon
        3. 10375.v1.98-96.patch
          0.6 kB
          Nicolas Liochon
        4. 10375.v1.patch
          0.6 kB
          Nicolas Liochon

          Issue Links

            Activity

              People

              • Assignee:
                nkeywal Nicolas Liochon
                Reporter:
                jmhsieh Jonathan Hsieh
              • Votes:
                0 Vote for this issue
                Watchers:
                6 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: