HBase
  1. HBase
  2. HBASE-10299

TestZKProcedure fails occasionally

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 0.98.0
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      I can reproduce this using JDK 6 on Ubuntu 12.

      Running org.apache.hadoop.hbase.procedure.TestZKProcedure
      Tests run: 4, Failures: 1, Errors: 0, Skipped: 0, Time elapsed: 5.941 sec <<< FAILURE!
      [...]
      Failed tests:   testMultiCohortWithMemberTimeoutDuringPrepare(org.apache.hadoop.hbase.procedure.TestZKProcedure): (..)
      

      Not seen running the test standalone. Quite rare, seen after 46 previous successful test suite runs. No failure trace available yet.

        Activity

        Andrew Purtell created issue -
        Andrew Purtell made changes -
        Field Original Value New Value
        Fix Version/s 0.98.0 [ 12323143 ]
        Andrew Purtell made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Assignee Andrew Purtell [ apurtell ]
        Fix Version/s 0.98.0 [ 12323143 ]
        Fix Version/s 0.99.0 [ 12325675 ]
        Resolution Duplicate [ 3 ]

          People

          • Assignee:
            Unassigned
            Reporter:
            Andrew Purtell
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development