HBase
  1. HBase
  2. HBASE-10245

Master aborts starting when region already in PENDING_OPEN state

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 0.94.14
    • Fix Version/s: None
    • Component/s: master
    • Labels:
      None

      Description

      Not sure if it's impacting other versions too.

      When master is starting while a region was PENDING_OPEN, master abort starting.

      java.lang.IllegalStateException: Unexpected state : page,www\x1Fhttp\x1F-1\x1F/vote/comment/27996/1/\x1Fnull,1379104524006.17bee313797fc1ce982c0e31fdb6620c. state=PENDING_OPEN, ts=1388065670415, server=node6,60020,1388027343261 .. Cannot transit it to OFFLINE.
      at org.apache.hadoop.hbase.master.AssignmentManager.setOfflineInZooKeeper(AssignmentManager.java:1890)
      at org.apache.hadoop.hbase.master.AssignmentManager.assign(AssignmentManager.java:1690)
      at org.apache.hadoop.hbase.master.AssignmentManager.assign(AssignmentManager.java:1426)
      at org.apache.hadoop.hbase.master.AssignmentManager.assign(AssignmentManager.java:1398)
      at org.apache.hadoop.hbase.master.AssignmentManager.assign(AssignmentManager.java:1393)
      at org.apache.hadoop.hbase.master.handler.ClosedRegionHandler.process(ClosedRegionHandler.java:105)
      at org.apache.hadoop.hbase.executor.EventHandler.run(EventHandler.java:175)
      at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
      at java.lang.Thread.run(Thread.java:744)

        Activity

        Vladimir Rodionov added a comment -

        I think its duplicate of HBASE-8912.

        Jean-Marc Spaggiari added a comment -

        Duplicate of HBASE-8912


          People

          • Assignee:
            Unassigned
            Reporter:
            Jean-Marc Spaggiari
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development