Uploaded image for project: 'HBase'
  1. HBase
  2. HBASE-10159

Replaced deprecated interface Closeable

    Details

    • Type: Task
    • Status: Closed
    • Priority: Trivial
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.98.0, 0.96.2, 0.99.0
    • Component/s: None
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      Hadoop interface Closeable has been deprecated for quite some time to favor java.io.Closeable. Since we support only hadoop 1.0 and above now, we can replace the deprecated Closeable with the java one. We can also clean up some hack we did as well, for example, HBASE-10029.

      https://github.com/apache/hadoop-common/blob/branch-1.0/src/core/org/apache/hadoop/io/Closeable.java

        Attachments

        1. trunk-10159.patch
          3 kB
          Jimmy Xiang
        2. trunk-10159_v2.patch
          2 kB
          Jimmy Xiang

          Issue Links

            Activity

              People

              • Assignee:
                jxiang Jimmy Xiang
                Reporter:
                jxiang Jimmy Xiang
              • Votes:
                0 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: