HBase
  1. HBase
  2. HBASE-10085

Some regions aren't re-assigned after a cluster restarts

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.96.1
    • Fix Version/s: 0.98.0, 0.96.1
    • Component/s: Region Assignment
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      We see this issue happened in a cluster restart:

      1) when shutdown a cluster, some regions are in offline state because no Region servers are available(stop RS and then Master)
      2) When the cluster restarts, the offlined regions are forced to be offline again and SSH skip re-assigning them by function AM.processServerShutdown as shown below.

      2013-12-03 10:41:56,686 INFO  [master:h2-ubuntu12-sec-1386048659-hbase-8:60000] master.AssignmentManager: Processing 873dbd8c269f44d0aefb0f66c5b53537 in state: M_ZK_REGION_OFFLINE
      2013-12-03 10:41:56,686 DEBUG [master:h2-ubuntu12-sec-1386048659-hbase-8:60000] master.AssignmentManager: RIT 873dbd8c269f44d0aefb0f66c5b53537 in state=M_ZK_REGION_OFFLINE was on deadserver; forcing offline
      ...
      2013-12-03 10:41:56,739 DEBUG [AM.-pool1-t8] master.AssignmentManager: Force region state offline {873dbd8c269f44d0aefb0f66c5b53537 state=OFFLINE, ts=1386067316737, server=h2-ubuntu12-sec-1386048659-hbase-6.cs1cloud.internal,60020,1386066968696}
      ...
      2013-12-03 10:41:57,223 WARN  [MASTER_SERVER_OPERATIONS-h2-ubuntu12-sec-1386048659-hbase-8:60000-3] master.RegionStates: THIS SHOULD NOT HAPPEN: unexpected {873dbd8c269f44d0aefb0f66c5b53537 state=OFFLINE, ts=1386067316737, server=h2-ubuntu12-sec-1386048659-hbase-6.cs1cloud.internal,60020,1386066968696} 
      
      1. hbase-10085.patch
        7 kB
        Jeffrey Zhong

        Issue Links

          Activity

          Jimmy Xiang added a comment -

          Do you see this issue in 0.96.0 or 0.96.1?

          Sergey Shelukhin added a comment -

          0.96.1, as of last Tuesday

          Jeffrey Zhong added a comment -

          Though we see this issue in the latest 0.96 code, it seems should happen in 0.96.0 code base from the code.

          Jimmy Xiang added a comment -

          In step 2, do you mean the whole cluster restarts (both master + rs)? Is it easy to add a unit test?

          Jeffrey Zhong added a comment -

          I mean whole cluster(master + rs). I'll add a unit test to cover this. Thanks.

          Jimmy Xiang added a comment -

          That's a little weird since the region state is transient. If the master also restarts, it should not know it's offline previously. I need to think it through.

          Jeffrey Zhong added a comment -

          The offline state was in ZK before master restarted.

          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12617100/hbase-10085.patch
          against trunk revision .

          +1 @author. The patch does not contain any @author tags.

          -1 tests included. The patch doesn't appear to include any new or modified tests.
          Please justify why no new tests are needed for this patch.
          Also please list what manual steps were performed to verify this patch.

          +1 hadoop1.0. The patch compiles against the hadoop 1.0 profile.

          +1 hadoop2.0. The patch compiles against the hadoop 2.0 profile.

          -1 javadoc. The javadoc tool appears to have generated 1 warning messages.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          +1 lineLengths. The patch does not introduce lines longer than 100

          -1 site. The patch appears to cause mvn site goal to fail.

          -1 core tests. The patch failed these unit tests:

          Test results: https://builds.apache.org/job/PreCommit-HBASE-Build/8058//testReport/
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8058//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-protocol.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8058//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-thrift.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8058//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-client.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8058//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-examples.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8058//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-hadoop1-compat.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8058//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-prefix-tree.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8058//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-common.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8058//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-server.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8058//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-hadoop-compat.html
          Console output: https://builds.apache.org/job/PreCommit-HBASE-Build/8058//console

          This message is automatically generated.

          Jimmy Xiang added a comment -

          If the region is offline based on ZK, the region is about to re-assign. In meta, the region should still have the old server name. That means it should be assigned by SSH in handling the old dead server, right?

          Jimmy Xiang added a comment -

          I see. The old dead server SSH skips this region since it is in transition.

          Jimmy Xiang added a comment -

          +1. Offline is also kind of pending open if the region is in transition. If you can add a unit test, it will be great. If it is hard to do, I am fine to go without one.

          Jimmy Xiang added a comment -

          Jeffrey Zhong, I thought it again and think we should not fix as in this patch. I think it is better to fix AM#processRegionsInTransition(RegionTransition, HRegionInfo, int) so that if the server is offline, instead of forcing offline the region, we can just restore its state based on the EventType. If the EventType is offline, set the region to pending_open. What do you think?

          Jeffrey Zhong added a comment -

          I created a unit test case for this issue and verified the fix.

          Just reset to PENDING_OPEN may not work in processRegionsInTransition. The assignment was indeed triggered while the issue is that the state stored in ZK cause the assignment skipped because assignment think the SSH would cover it later(this is expected).

          Later the two old server SSHs both started as expected while both of them skippped the region assignment:
          The source server SSH thought the region was already in RIT state so skipped it(this is expected) while the destination server SSH thought the RIT is in unexpected state so skipping it which I think it's problematic as there are several scenarios that RITs could be in offline state during region assignment.

          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12617308/hbase-10085.patch
          against trunk revision .

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 3 new or modified tests.

          +1 hadoop1.0. The patch compiles against the hadoop 1.0 profile.

          +1 hadoop1.1. The patch compiles against the hadoop 1.1 profile.

          -1 javadoc. The javadoc tool appears to have generated 1 warning messages.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          -1 findbugs. The patch appears to introduce 2 new Findbugs (version 1.3.9) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          +1 lineLengths. The patch does not introduce lines longer than 100

          -1 site. The patch appears to cause mvn site goal to fail.

          +1 core tests. The patch passed unit tests in .

          Test results: https://builds.apache.org/job/PreCommit-HBASE-Build/8069//testReport/
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8069//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-hadoop2-compat.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8069//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-prefix-tree.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8069//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-client.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8069//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-common.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8069//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-protocol.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8069//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-server.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8069//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-examples.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8069//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-thrift.html
          Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/8069//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-hadoop-compat.html
          Console output: https://builds.apache.org/job/PreCommit-HBASE-Build/8069//console

          This message is automatically generated.

          Jimmy Xiang added a comment -

          +1 on the new patch. This is the other fix I thought about too. My original concern about this fix is that it changed the state machine a little. I think it is fine since state offline + in-transition is kind of pending open.

          Jimmy Xiang added a comment -

          Jeffrey Zhong, before you commit it, could you fix the format a little bit? For example:

          +            || !(regionState.isFailedClose() || regionState.isPendingOpenOrOpening() || regionState
          +                .isOffline())) {
          

          to something like

          +            || !(regionState.isFailedClose() || regionState.isPendingOpenOrOpening()
          +                 || regionState.isOffline())) {
          

          By the way, the new test is a little flaky. Instead of restarting the whole mini cluster, can we just restart the master? Also increase the timeout a little?

          Thanks.

          Jeffrey Zhong added a comment -

          Thanks Jimmy Xiang for the reviews! I've integrated the fix into trunk, 0.98 and 0.96 branch. The javadoc and findbug warnings are not related to this patch. Thanks.

          Jimmy Xiang added a comment -

          Never mind about my previous comment. I can address it in HBASE-10090. Thanks.

          Jeffrey Zhong added a comment -

          I checked in at the same time as your comments. The committed patch has updated format which is from our Apache template auto formatting.

          The reason to restart whole cluster is that I need to trigger SSH on both old RSs(source RS and dst RS in a region assignment) to repro the exact issue to verify the fix.

          Jimmy Xiang added a comment -

          The reason to restart whole cluster is that I need to trigger SSH on both old RSs(source RS and dst RS in a region assignment) to repro the exact issue to verify the fix.

          That's my understanding too. But sometimes, it takes a while to restart the cluster. Let me think about it.

          Jimmy Xiang added a comment -

          Jeffrey Zhong, I filed an issue on the test: HBASE-10101. Do you want to take a look?

          Jeffrey Zhong added a comment -

          ok. Let me check it. Thanks.

          Hudson added a comment -

          FAILURE: Integrated in hbase-0.96 #217 (See https://builds.apache.org/job/hbase-0.96/217/)
          HBASE-10085: Some regions aren't re-assigned after a master restarts (jeffreyz: rev 1548728)

          • /hbase/branches/0.96/hbase-server/src/main/java/org/apache/hadoop/hbase/master/AssignmentManager.java
          • /hbase/branches/0.96/hbase-server/src/main/java/org/apache/hadoop/hbase/master/RegionStates.java
          • /hbase/branches/0.96/hbase-server/src/test/java/org/apache/hadoop/hbase/master/TestAssignmentManagerOnCluster.java
          Hudson added a comment -

          SUCCESS: Integrated in HBase-TRUNK #4715 (See https://builds.apache.org/job/HBase-TRUNK/4715/)
          HBASE-10085: Some regions aren't re-assigned after a master restarts (jeffreyz: rev 1548726)

          • /hbase/trunk/hbase-server/src/main/java/org/apache/hadoop/hbase/master/AssignmentManager.java
          • /hbase/trunk/hbase-server/src/main/java/org/apache/hadoop/hbase/master/RegionStates.java
          • /hbase/trunk/hbase-server/src/test/java/org/apache/hadoop/hbase/master/TestAssignmentManagerOnCluster.java
          Hudson added a comment -

          FAILURE: Integrated in hbase-0.96-hadoop2 #143 (See https://builds.apache.org/job/hbase-0.96-hadoop2/143/)
          HBASE-10085: Some regions aren't re-assigned after a master restarts (jeffreyz: rev 1548728)

          • /hbase/branches/0.96/hbase-server/src/main/java/org/apache/hadoop/hbase/master/AssignmentManager.java
          • /hbase/branches/0.96/hbase-server/src/main/java/org/apache/hadoop/hbase/master/RegionStates.java
          • /hbase/branches/0.96/hbase-server/src/test/java/org/apache/hadoop/hbase/master/TestAssignmentManagerOnCluster.java
          stack added a comment -

          Released in 0.96.1. Issue closed.


            People

            • Assignee:
              Jeffrey Zhong
              Reporter:
              Jeffrey Zhong
            • Votes:
              0 Vote for this issue
              Watchers:
              7 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development