Uploaded image for project: 'Apache HAWQ'
  1. Apache HAWQ
  2. HAWQ-1277

The "make" command generates an error on CentOS 7 when --with-perl is run in configure.

Attach filesAttach ScreenshotVotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.1.0.0-incubating
    • Component/s: Build
    • Labels:
      None

      Description

      The following "make" error is encountered on CentOS 7 when --with-perl is run in configure:

      make[3]: Entering directory `/home/centos/apache-hawq-src-2.1.0.0-incubating/src/pl/plperl'
      "/usr/bin/perl" ./text2macro.pl<http://text2macro.pl> --strip='^(\#.*|\s*)$' plc_perlboot.pl<http://plc_perlboot.pl> plc_trusted.pl<http://plc_trusted.pl> > perlchunks.h
      "/usr/bin/perl" plperl_opmask.pl<http://plperl_opmask.pl> plperl_opmask.h
      "/usr/bin/perl" /usr/share/perl5/ExtUtils/xsubpp -typemap /usr/share/perl5/ExtUtils/typemap SPI.xs >SPI.c
      "/usr/bin/perl" /usr/share/perl5/ExtUtils/xsubpp -typemap /usr/share/perl5/ExtUtils/typemap Util.xs >Util.c
      Can't open perl script "/usr/share/perl5/ExtUtils/xsubpp": No such file or directory
      Can't open perl script "/usr/share/perl5/ExtUtils/xsubpp": No such file or directory
      make[3]: *** [SPI.c] Error 2
      make[3]: *** Deleting file `SPI.c'
      make[3]: *** Waiting for unfinished jobs....
      make[3]: *** [Util.c] Error 2
      make[3]: *** Deleting file `Util.c'
      make[3]: Leaving directory `/home/centos/apache-hawq-src-2.1.0.0-incubating/src/pl/plperl'
      make[2]: *** [all] Error 1
      make[2]: Leaving directory `/home/centos/apache-hawq-src-2.1.0.0-incubating/src/pl'
      make[1]: *** [all] Error 2
      make[1]: Leaving directory `/home/centos/apache-hawq-src-2.1.0.0-incubating/src'
      make: *** [all] Error 2
      

      I also have found a fix for this which was backported from PostgreSQL to the Greenplum DB master branch a year ago by Heikki Linnakangas<https://github.com/hlinnaka> (Original PostgreSQL committer Andrew Dunstan <andrew@dunslane.net<andrew@dunslane.net>>):

      https://github.com/greenplum-db/gpdb/commit/f493756a5ac8a90ff1d5e3b84f38a153c9f80b9c#diff-97d34e5e3684082069b6c85876df9107

        Attachments

          Activity

            People

            • Assignee:
              espino Ed Espino
              Reporter:
              espino Ed Espino

              Dates

              • Created:
                Updated:
                Resolved:

                Issue deployment