Harmony
  1. Harmony
  2. HARMONY-944

[classlib][text] java.text.BreakIterator.getInt(byte[], Integer.MAX_VALUE) does not throw ArrayIndexOutOfBoundsException

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Classlib
    • Labels:
      None

      Description

      The harmony methods java.text.BreakIterator.getShort/Int/Long(byte[], Integer.MAX_VALUE) does not throw ArrayIndexOutOfBoundsException.

      1. 944.diff
        5 kB
        spark shen
      2. BreakIterator.patch
        10 kB
        Vladimir Ivanov

        Activity

        Paulex Yang added a comment -

        Vladimir and Spark, updated patch applied at revision r448771, thanks a lot for this enhancement, please verify the problem is fully resolved as you expected.

        spark shen added a comment -

        Would you please try this new patch? Since so many commits these days, the old patch is outdated.

        Best regards

        Vladimir Ivanov added a comment -

        unit tests + patch


          People

          • Assignee:
            Paulex Yang
            Reporter:
            Vladimir Ivanov
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development