Harmony
  1. Harmony
  2. HARMONY-937

[classlib][text] compatibility: java.text.Collator.compare(null,null) returns true while RI throws NPE

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Cannot Reproduce
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Classlib
    • Labels:
      None

      Description

      The harmony method java.text.Collator.compare(String, String) returns 0 with both 'null' while RI throws NPE.

      ================= test.java ======================
      import java.text.*;

      public class test {
      public static void main (String[] args) throws Exception {
      RuleBasedCollator rc = new RuleBasedCollator("< a< b< c< d");
      try

      { System.out.println("res = " + rc.compare(null, null)); }

      catch (Exception e)

      { System.out.println("1: " + e); }


      try

      { System.out.println("res = " + rc.compare("a", null)); }

      catch (Exception e)

      { System.out.println("2: " + e); }


      try

      { System.out.println("res = " + rc.compare(null, "a")); }

      catch (Exception e)

      { System.out.println("3: " + e); }


      }
      }
      ==============================================

      Output
      C:\tmp\tmp17>C:\jrockit-jdk1.5.0-windows-ia32\bin\java.exe -cp . -showversion test
      java version "1.5.0"
      Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0-b64)
      BEA WebLogic JRockit(R) (build dra-38972-20041208-2001-win-ia32, R25.0.0-75, GC: System optimized over throughput (initial strategy singleparpar))

      1: java.lang.NullPointerException
      2: java.lang.NullPointerException
      3: java.lang.NullPointerException

      C:\tmp\tmp17>C:\harmony\trunk_0427\deploy\jdk\jre\bin\java.exe -cp . -showversion test
      java version 1.5 (subset)

      (c) Copyright 1991, 2006 The Apache Software Foundation or its licensors, as applicable.
      res = 0
      2: java.lang.NullPointerException
      3: java.lang.NullPointerException

        Activity

        Vladimir Ivanov created issue -
        Vladimir Ivanov added a comment -

        unit test+patch

        Vladimir Ivanov made changes -
        Field Original Value New Value
        Attachment RuleBasedCollator.patch [ 12337273 ]
        spark shen added a comment -

        Seems this bug has already been fixed. Would any commiter close it?(Patching is not necessary any more)

        Best regards

        Paulex Yang added a comment -

        Vladimir and Spark, thank you for look at this. Vladimir, please verify if this issue still can reproduced or not.

        Paulex Yang made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Cannot Reproduce [ 5 ]
        Paulex Yang made changes -
        Assignee Paulex Yang [ paulex ]
        Vladimir Ivanov added a comment -

        also can't reproduce so should be closed.
        thanks, Vladimir


          People

          • Assignee:
            Paulex Yang
            Reporter:
            Vladimir Ivanov
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development