Harmony
  1. Harmony
  2. HARMONY-895

[classlib][net] java.net.URL((URL) null, String, handler) does not throw MalformedURLException for unknown protocol

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Classlib
    • Labels:
      None

      Description

      The j2se spec says for java.net.URL((URL) null, String spec, URLStreamHandler handler):
      "Throws: MalformedURLException - if no protocol is specified, or an unknown protocol is found."

      But Harmony does not throw exception for spec=":"

      ================= test.java ========================
      import java.net.*;
      import java.io.*;

      public class test {
      public static void main (String[] args) {
      try

      { System.out.println("res = " + new URL((URL) null, ":", new TestURLStreamHandler())); }

      catch (Exception e)

      { e.printStackTrace(); }


      }
      }
      class TestURLStreamHandler extends URLStreamHandler {
      public URLConnection openConnection(URL arg0) throws IOException {
      try

      { return arg0.openConnection(); }

      catch (Throwable e)

      { return null; }

      }
      }
      ================================================

      Output:
      C:\tmp\tmp17>C:\jrockit-jdk1.5.0-windows-ia32\bin\java.exe -cp . -showversion test
      java version "1.5.0"
      Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0-b64)
      BEA WebLogic JRockit(R) (build dra-38972-20041208-2001-win-ia32, R25.0.0-75, GC: System optimized over throughput (initial strategy singleparpar))

      java.net.MalformedURLException: no protocol: :
      at java.net.URL.<init>(URL.java:567)
      at test.main(test.java:7)

      C:\tmp\tmp17>C:\harmony\trunk_0427\deploy\jdk\jre\bin\java.exe -cp . -showversion test
      java version 1.5 (subset)

      (c) Copyright 1991, 2006 The Apache Software Foundation or its licensors, as applicable.
      res = :

      C:\tmp\tmp17>C:\harmony\drlvm\trunk\build\win_ia32_msvc_debug\deploy\jre\bin\ij -cp . -showversion test
      Apache Harmony DRLVM HEAD-4807 (2006-05-02), Windows/ia32/msvc 1310, debug
      res = :

      1. URL.patch
        0.6 kB
        Vladimir Ivanov
      2. URLTest.patch
        1.0 kB
        Vladimir Ivanov

        Issue Links

          Activity

          Paulex Yang added a comment -

          Verified by Tony and Vladimir.

          Vladimir Ivanov added a comment -

          also cann't reproduce. Should be closed.
          thanks, Vladimir

          Paulex Yang added a comment -

          Sorry, the resolution should be "Cannot reproduce", it is my carelessness to leave it as fixed.

          Paulex Yang added a comment -

          Tony, thank you for looking at this.

          Vladimir, please verify that the issue has been fully fixed, thank you.

          Paulex Yang added a comment -

          Seems it is fixed by the patch for HARMONY-1135.

          Tony Wu added a comment -

          seems fixed in harmony 1135, it is no longer a bug in latest code (r446492)

          Vladimir Ivanov added a comment -

          patch

          Vladimir Ivanov added a comment -

          unit test


            People

            • Assignee:
              Unassigned
              Reporter:
              Vladimir Ivanov
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development