Harmony
  1. Harmony
  2. HARMONY-877

[classlib][lang] compatibility: Harmony method ClassLoader.getResource(null) returns null while RI throws NPE

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Classlib
    • Labels:
      None
    • Patch Info:
      Patch Available

      Description

      The Harmony methods ClassLoader.getResource(null) and ClassLoader.getResourceAsStream(null) returns null while RI throws NPE.

      ==================== test.java ====================
      public class test {
      public static void main (String[] args) {
      try

      { System.out.println("res = " + ClassLoader.getSystemClassLoader().getResource(null)); }

      catch (NullPointerException e)

      { System.out.println("exception: " + e); }

      try

      { System.out.println("res = " + ClassLoader.getSystemClassLoader().getResourceAsStream(null)); }

      catch (NullPointerException e)

      { System.out.println("exception: " + e); }

      }
      }
      ===============================================

      Output:
      C:\tmp\tmp17>C:\jrockit-jdk1.5.0-windows-ia32\bin\java.exe -cp . -showversion test
      java version "1.5.0"
      Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0-b64)
      BEA WebLogic JRockit(R) (build dra-38972-20041208-2001-win-ia32, R25.0.0-75, GC: System optimized over throughput (initial strategy singleparpar))

      exception: java.lang.NullPointerException: name
      exception: java.lang.NullPointerException: name

      C:\tmp\tmp17>C:\harmony\trunk_0427\deploy\jdk\jre\bin\java.exe -cp . -showversion test
      java version 1.5 (subset)

      (c) Copyright 1991, 2006 The Apache Software Foundation or its licensors, as applicable.
      res = null
      res = null

      C:\tmp\tmp17>C:\harmony\drlvm\trunk\build\win_ia32_msvc_debug\deploy\jre\bin\ij -cp . -showversion test
      Apache Harmony DRLVM HEAD-4807 (2006-05-02), Windows/ia32/msvc 1310, debug
      res = null
      res = null

      1. HARMONY-877.diff
        0.9 kB
        Alexey Petrenko

        Issue Links

          Activity

          Alexey Petrenko added a comment -

          Fix for drlvm

          Alexey Petrenko added a comment -

          The issue is not reproducible on current DRLVM sources. Regression test added.
          Vladimir, please verify.

          Vladimir Ivanov added a comment -

          verified, thanks. this issue is not reproducible on DRLVM but is reproduced on the IBMVM.

          Alexey Petrenko added a comment -

          I've created a new issue against IBM VME.


            People

            • Assignee:
              Alexey Petrenko
              Reporter:
              Vladimir Ivanov
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development