Harmony
  1. Harmony
  2. HARMONY-833

[classlib][lang] unexpected IllegalCharsetNameException for ByteArrayOutputStream().toString("~]?-??-?");

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Classlib
    • Labels:
      None

      Description

      The Harmony method ByteArrayOutputStream().toString("~]????") throws IllegalCharsetNameException while spec requires UnsupportedEncodingException.

      ============ test.java =========================
      import java.io.*;

      public class test {
      public static void main (String[] args) {
      try

      { new ByteArrayOutputStream().toString("~]?-??-?"); }

      catch (Exception e)

      { System.out.println("" + e); }


      }
      }
      ============================================

      Output:
      C:\tmp\tmp17>C:\jrockit-jdk1.5.0-windows-ia32\bin\java.exe -showversion test
      java version "1.5.0"
      Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0-b64)
      BEA WebLogic JRockit(R) (build dra-38972-20041208-2001-win-ia32, R25.0.0-75, GC: System optimized over throughput (initial strategy singleparpar))

      java.io.UnsupportedEncodingException: ~]????

      C:\tmp\tmp17>C:\harmony\trunk_0427\deploy\jdk\jre\bin\java.exe -showversion test
      java version 1.5 (subset)

      (c) Copyright 1991, 2006 The Apache Software Foundation or its licensors, as applicable.
      java.nio.charset.IllegalCharsetNameException: The illegal charset name is "~]????".

      1. String.patch
        0.7 kB
        Vladimir Ivanov
      2. ByteArrayOutputStreamTest.patch
        0.7 kB
        Vladimir Ivanov

        Activity

        spark shen added a comment -

        Checked against r431832

        Paulex Yang made changes -
        Status Open [ 1 ] Closed [ 6 ]
        Resolution Cannot Reproduce [ 5 ]
        Paulex Yang added a comment -

        Verified by Spark, cannot reproduce at revision r447176.

        spark shen added a comment -

        Seems this bug has already been fixed. Would any commiter close it?

        Best regards

        Vladimir Ivanov made changes -
        Attachment ByteArrayOutputStreamTest.patch [ 12336646 ]
        Vladimir Ivanov added a comment -

        unit test

        Vladimir Ivanov made changes -
        Field Original Value New Value
        Attachment String.patch [ 12336645 ]
        Vladimir Ivanov added a comment -

        patch

        Vladimir Ivanov created issue -

          People

          • Assignee:
            Unassigned
            Reporter:
            Vladimir Ivanov
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development