Harmony
  1. Harmony
  2. HARMONY-6617

[classlib]Upgrade ICU4J4.2.1 to ICU4J4.4.1.1

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 5.0M16
    • Component/s: Classlib
    • Labels:
      None
    • Patch Info:
      Patch Available

      Description

      This release contain many bug fix and also improve the performance. please refer to http://source.icu-project.org/repos/icu/icu4j/tags/release-4-4-1-1/readme.html for details

        Activity

        deven you made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Regis Xu added a comment -

        HARMONY-6632 is addressed test_hasNextLine_sequence failure, after applied the patch, it could pass either standalone and batch run.

        Hudson added a comment -

        Integrated in Harmony-select-1.5-head-linux-x86_64 #107 (See https://hudson.apache.org/hudson/job/Harmony-select-1.5-head-linux-x86_64/107/)
        Apply patch for HARMONY-6617: [classlib]Upgrade ICU4J4.2.1 to ICU4J4.4.1.1

        Hudson added a comment -

        Integrated in Harmony-1.5-head-linux-x86_64 #945 (See https://hudson.apache.org/hudson/job/Harmony-1.5-head-linux-x86_64/945/)
        Apply patch for HARMONY-6617: [classlib]Upgrade ICU4J4.2.1 to ICU4J4.4.1.1

        Regis Xu made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Fix Version/s 5.0M16 [ 12315337 ]
        Resolution Fixed [ 1 ]
        Regis Xu added a comment -

        Deven, the patch was applied to trunk at r997554, please verify. Thanks.

        Regis Xu added a comment -

        I can see the same thing before applying the patch: running ScannerTest standalone passed, but failed in batch run, so it's not caused by this patch, will apply soon.

        Regis Xu added a comment -

        Running ScannerTest standalone, can't see the failure.

        Regis Xu added a comment -

        Applied the patch I got a unit test failure that is not seen before the patch:
        test_hasNextLine_sequence

        expected:<1> but was:<0>

        junit.framework.AssertionFailedError: expected:<1> but was:<0>
        at org.apache.harmony.luni.tests.java.util.ScannerTest.test_hasNextLine_sequence(ScannerTest.java:5696)
        at java.lang.reflect.VMReflection.invokeMethod(VMReflection.java)

        Regis Xu made changes -
        Assignee Regis Xu [ regis_xu ]
        deven you added a comment -

        RI does not support this format, it is beyond java spec.

        Regis Xu added a comment -

        Hi Deven,

        You mentioned that pattern (123) is not supported by icu4j, is this change compatible with java spec?

        deven you added a comment -

        Since this JIRA contains some fixes due to ICU4J changes, I recommend adding following description:
        Upgrade ICU4J from 4.2.1 to 4.4.1.1, fix some bugs because of the change of ICUC4J:
        1. Fix Currency.test_getInstanceLjava_util_Locale() failur for Locale("", "AQ") of Currency.getInstance(Locale), adding logic to check IllegalArgumentException:
        Call ICU's Currency.getInstance(Locale). If null is returned, check if country code is know or not in Harmony's wrapper. If the country code is unknown, then throw IAE.
        2. Remove test pattern (123) from the ScannerTest since ICU4J no longer support this pattern due to standard change.

        deven you made changes -
        Field Original Value New Value
        Attachment HARMONY-6617.diff [ 12451759 ]
        deven you created issue -

          People

          • Assignee:
            Regis Xu
            Reporter:
            deven you
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Time Tracking

              Estimated:
              Original Estimate - 96h
              96h
              Remaining:
              Remaining Estimate - 96h
              96h
              Logged:
              Time Spent - Not Specified
              Not Specified

                Development