Harmony
  1. Harmony
  2. HARMONY-5481

[drlvm][shutdown] adding a native callback which executes on VM shutdown

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: DRLVM
    • Labels:
      None
    • Patch Info:
      Patch Available

      Description

      Modifying shutdown sequence for DestroyJavaVM, System.exit() and Ctrl+C shutdown paths by adding a native callback. The callback is currently used for dumping VM statistics.

        Issue Links

          Activity

          Alexei Fedotov added a comment -

          I'm investing a bit more into testing the patch myself, but any review comments are very welcome right now.

          Alexei Fedotov added a comment -

          Improved patch by flushing statistics flushes fully.

          Pavel Pervov added a comment -

          Alexei,

          If you want to flush statistics, it would be better to name the function correspondingly. Otherwise, shutdown paths have nothing in common for DestroyJavaVM, System.exit, and Ctrl+C. Well, at least last two does not guarantee safe shutdown of virtual machine.

          Alexei Fedotov added a comment -

          Pavel, thanks!
          The updated patch at HARMONY-5499 contains a function renamed to exec_native_shutdown_sequence()

          Pavel Pervov added a comment -

          HARMONY-5499 contains the patch for this JIRA too.

          Pavel Pervov added a comment -

          As HARMONY-5499 is committed this is fixed too.

          Alexei Fedotov added a comment -

          Thanks, Pavel.
          The issue is verified.


            People

            • Assignee:
              Pavel Pervov
              Reporter:
              Alexei Fedotov
            • Votes:
              1 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development