Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Classlib
    • Labels:
      None

      Description

      The following statements throw IllegalCharsetNameException but the RI throws UnsupportedEncodingException:

      new String(byte_array, "");
      (new String()).getBytes("");

        Activity

        Tim Ellison added a comment -

        Closed in duplicate HARMONY-663.

        Vladimir Ivanov added a comment -

        The issue 663 (duplicate of this one) was fixed so it may be closed.

        Mark Hindess added a comment -

        Patch with tests and fix.


          People

          • Assignee:
            Tim Ellison
            Reporter:
            Mark Hindess
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development