Harmony
  1. Harmony
  2. HARMONY-4771

[drlvm][init] -verbose option doesn't work on linux32

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: DRLVM
    • Labels:
      None
    • Environment:
      linux / x86

      Description

      output:
      ./harmony_build-r574120-x86-linux/bin/java -verbose -cp . Hello
      GC: call GC init...

      terminate called after throwing an instance of 'std::length_error'
      what(): basic_string::reserve
      Aborted

      It works on win32, lnx64.

        Activity

        Naumova Natalya created issue -
        Vladimir Beliaev added a comment -

        The bug is not reproducible for me on latest Harmony in both debug and release build for Linux x86:

        • svn = r576594, (Sep 18 2007), Linux/ia32/gcc 3.3.3, release build
        • svn = r576770, (Sep 18 2007), Linux/ia32/gcc 3.3.3, debug build

        $ ./trunk-release/working_vm/build/deploy/jdk/jre/bin/java -showversion -verbose -cp . HWA
        Apache Harmony Launcher : (c) Copyright 1991, 2006 The Apache Software Foundation or its licensors, as applicable.
        java version "1.5.0"
        pre-alpha : not complete or compatible
        svn = r576594, (Sep 18 2007), Linux/ia32/gcc 3.3.3, release build
        http://harmony.apache.org
        GC: call GC init...
        <skipped...>
        [Loaded HWA by java/lang/ClassLoader$SystemClassLoader]
        Hello, HWA!
        [Loaded java/lang/InterruptedException from .../trunk-release/working_vm/build/deploy/jdk/jre/lib/boot/luni.jar
        <skipped...>
        GC: end of GC wrapup

        ./trunk-debug/working_vm/build/deploy/jdk/jre/bin/java -showversion -verbose -cp . HWA
        Apache Harmony Launcher : (c) Copyright 1991, 2006 The Apache Software Foundation or its licensors, as applicable.
        java version "1.5.0"
        pre-alpha : not complete or compatible
        svn = r576770, (Sep 18 2007), Linux/ia32/gcc 3.3.3, debug build
        http://harmony.apache.org
        GC: call GC init...
        <skipped...>
        [Loaded HWA by java/lang/ClassLoader$SystemClassLoader]
        Hello, HWA!
        [Loaded java/lang/InterruptedException from ...trunk-debug/working_vm/build/deploy/jdk/jre/lib/boot/luni.jar]
        <skipped...>
        GC: end of GC wrapup

        Please double check on latest revision and either confirm the bug exists or close it is "not reproducible" or "works for me"...

        What exact Linux version did you use?

        Thanks
        Vladimir Beliaev

        Naumova Natalya added a comment -

        I've checked and it's reproducible for me on 577137 rev also. I've used release version.
        ./harmony_build-r577137-x86-linux/bin/jav
        a -showversion -verbose -cp . Hello
        Apache Harmony Launcher : (c) Copyright 1991, 2006 The Apache Software Foundation or its licensors, as applicable.
        java version "1.5.0"
        pre-alpha : not complete or compatible
        svn = r577137, (Sep 19 2007), Linux/ia32/gcc 3.4.2, release build
        http://harmony.apache.org
        GC: call GC init...

        terminate called after throwing an instance of 'std::length_error'
        what(): basic_string::reserve
        Aborted

        Linux32/SuSe9/gcc3.3.3
        I'll check on debug and report asap.

        Naumova Natalya added a comment -

        I've checked on r579041 version: bug is reproduced on release DRLVM: everything is OK with debug version.

        Gregory Shimansky made changes -
        Field Original Value New Value
        Environment linux32 linux / x86
        Summary -verbose option doesn't work on linux32 [drlvm][init] -verbose option doesn't work on linux32
        Alexei Fedotov added a comment -

        Hello Natalia,
        I have rechecked this issue, it does not seem reproducible. Are you still able to reproduce it?

        $ target/hdk/jdk/jre/bin/java -showversion -verbose -cp . Hello 2>&1 | head -20
        Apache Harmony Launcher : (c) Copyright 1991, 2007 The Apache Software Foundation or its licensors, as applicable.
        java version "1.5.0"
        pre-alpha : not complete or compatible
        svn = r618306, (Feb 4 2008), Linux/ia32/gcc 4.1.2, release build
        http://harmony.apache.org
        GC: call GC init...

        GC_Gen initial:
        max heap size: 256MB
        min heap size: 16MB
        initial heap size: 16MB
        initial num collectors: 0
        initial nos size: 9MB
        nos collection algo: partial forward
        initial mos size: 2MB
        mos collection algo: move compact
        initial los size: 4MB

        GC: end of GC init
        [...]

        Alexei Fedotov added a comment -

        Natalya,
        I succeed in running -verbose on your computer. I believe the problem might be in your customized build scripts. Could you please check if my version works for you? Thanks.

        Naumova Natalya added a comment -

        Alexei,
        yes it works. Looks like it a build issue really (for my two machines), so i'll close it as not reproducible.
        thanks.

        Naumova Natalya made changes -
        Resolution Cannot Reproduce [ 5 ]
        Status Open [ 1 ] Closed [ 6 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Closed Closed
        148d 21h 34m 1 Naumova Natalya 06/Feb/08 12:36

          People

          • Assignee:
            Unassigned
            Reporter:
            Naumova Natalya
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development