Harmony
  1. Harmony
  2. HARMONY-342

Java 5 Enhancement: new Java5 methods in java.util.Collections class

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Estimated Complexity:
      Novice

      Description

      The patch implements new Java 5 methods (emptyXXX, checkedXXX and disjoint) for java.util.Collections class. The patch also includes test cases updates.

      1. Collections.patch
        33 kB
        Marina V. Goldburt
      2. SortedSet.patch
        3 kB
        Marina V. Goldburt

        Activity

        Mikhail Loenko added a comment -

        modified patch applied in revision 409066
        never-used private class CheckedSortedSet was not committed
        Marina please let me know if this class was intended for a future use

        Marina V. Goldburt added a comment -

        The class is used by the public function checkedSortedSet().
        The patch to add the function and the class is attached.
        Please review and apply.

        Marina V. Goldburt added a comment -

        patch to add checkedSortedSet() function

        Mikhail Loenko added a comment -

        the second patch applied in revision 410464
        Marina, please check that it works as expected

        Marina V. Goldburt added a comment -

        Everything seems to be ok.
        Thanks, Marina.

        Mark Hindess added a comment -

        This has been verified. Closing.


          People

          • Assignee:
            Mikhail Loenko
            Reporter:
            Marina V. Goldburt
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development