Harmony
  1. Harmony
  2. HARMONY-2387

[classlib][luni] org.apache.harmony.tests.internal.net.www.protocol.http.HttpURLConnectionTest.testUsingProxy() intermittently fails

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Classlib
    • Labels:
      None
    • Environment:
      SuSE9, ia32, multi-processor

      Description

      $ while ../../drlvm/trunk/build/lnx_ia32_gcc_debug/deploy/jre/bin/java -cp modules/luni/bin/test:depends/jars/junit_3.8.2/junit.jar junit.textui.TestRunner org.apache.harmony.tests.internal.net.www.protocol.http.HttpURLConnectionTest; do date; done 2>&1 | tee log.txt
      [...]
      ..E..
      Time: 1.133
      There was 1 error:
      1) testUsingProxy(org.apache.harmony.tests.internal.net.www.protocol.http.HttpURLConnectionTest
      )java.net.SocketException: No such file or directory
      at org.apache.harmony.luni.platform.OSNetworkSystem.connectStreamWithTimeoutSocketImpl(
      OSNetworkSystem.java)
      at org.apache.harmony.luni.platform.OSNetworkSystem.connectStreamWithTimeoutSocket(OSNe
      tworkSystem.java)
      at org.apache.harmony.luni.net.PlainSocketImpl.connect(PlainSocketImpl.java:216)
      at org.apache.harmony.luni.net.PlainSocketImpl.connect(PlainSocketImpl.java:496)
      at java.net.Socket.connect(Socket.java:978)
      at org.apache.harmony.luni.internal.net.www.protocol.http.HttpURLConnection.getHTTPConn
      ection(HttpURLConnection.java:630)
      at org.apache.harmony.luni.internal.net.www.protocol.http.HttpURLConnection.connect(Htt
      pURLConnection.java:581)
      at org.apache.harmony.tests.internal.net.www.protocol.http.HttpURLConnectionTest.testUs
      ingProxy(HttpURLConnectionTest.java:203)
      at java.lang.reflect.VMReflection.invokeMethod(Native Method)

      FAILURES!!!
      Tests run: 4, Failures: 0, Errors: 1

      1. Harmony-2387.diff
        1.0 kB
        Ruth Cao
      2. Harmony-2387.diff
        0.7 kB
        Ruth Cao

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        94d 7h 42m 1 Paulex Yang 05/Mar/07 07:56
        Resolved Resolved Reopened Reopened
        2d 23h 37m 1 Paulex Yang 08/Mar/07 07:33
        Reopened Reopened Resolved Resolved
        14d 1h 31m 1 Paulex Yang 22/Mar/07 09:05
        Resolved Resolved Closed Closed
        347d 4h 15m 1 Alexei Fedotov 03/Mar/08 13:21
        Alexei Fedotov made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Alexei Fedotov added a comment -

        Thanks, Ruth, Paulex,
        the test works reliably.

        Ruth Cao added a comment -

        Paulex, The fix looks fine. Thank you.

        Paulex Yang made changes -
        Status Reopened [ 4 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Paulex Yang added a comment -

        Ruth, new patch applied at revision r521157, thanks a lot, please verify.

        Ruth Cao made changes -
        Attachment Harmony-2387.diff [ 12353086 ]
        Ruth Cao added a comment -

        Hi Paulex,

        I've created a new patch for this jira, modifying the entry just in the hysock_connect_with_timeout method instead of findError. May you pls validate it?

        Thanks,
        Ruth

        Paulex Yang added a comment -

        patch recovered at revision r515959

        Paulex Yang made changes -
        Resolution Fixed [ 1 ]
        Status Resolved [ 5 ] Reopened [ 4 ]
        Paulex Yang added a comment -

        Cause Archive and Security test failures on DRLVM/Linux.

        Discussion in the mailing list:
        http://mail-archives.apache.org/mod_mbox/harmony-dev/200703.mbox/%3c7273946b0703052053l468d39aag9a162eadca75e69@mail.gmail.com%3e

        Paulex Yang made changes -
        Resolution Fixed [ 1 ]
        Status Open [ 1 ] Resolved [ 5 ]
        Paulex Yang added a comment -

        Ruth, patch applied at revision r514596, thanks a lot for this enhancement.

        Alexei, please verify if the issue is resolved as you expected.

        Paulex Yang made changes -
        Assignee Paulex Yang [ paulex ]
        Ruth Cao made changes -
        Field Original Value New Value
        Attachment Harmony-2387.diff [ 12350739 ]
        Ruth Cao added a comment -

        May somebody pls try this patch?

        Alexei Fedotov created issue -

          People

          • Assignee:
            Paulex Yang
            Reporter:
            Alexei Fedotov
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development