Harmony
  1. Harmony
  2. HARMONY-2367

[drlvm][unit] javax.swing.text.PlainViewI18N_VisualPositionTest intermittently crashes VM

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: DRLVM
    • Labels:
      None
    • Environment:
      SuSE 9, ia32, multi-processor, r480712

      Description

      I've reproduced the problem once from 54 runs:

      ....
      SIGSEGV in VM code.
      Stack trace:
      Time: 2.182

      OK (4 tests)

      [the process hangs]

        Activity

        Alexei Fedotov created issue -
        Alexei Fedotov made changes -
        Field Original Value New Value
        Component/s DRLVM [ 12311272 ]
        Alexei Fedotov made changes -
        Summary [drlvm][unit] javax.swing.text.PlainViewI18N_VisualPositionTest intermittently crashes VM [classlib][swing] javax.swing.text.PlainViewI18N_VisualPositionTest fails intermittently as a part of the whole module test run
        Component/s Classlib [ 12310560 ]
        Component/s DRLVM [ 12311272 ]
        Alexei Fedotov made changes -
        Component/s DRLVM [ 12311272 ]
        Summary [classlib][swing] javax.swing.text.PlainViewI18N_VisualPositionTest fails intermittently as a part of the whole module test run [drlvm][unit] javax.swing.text.PlainViewI18N_VisualPositionTest intermittently crashes VM
        Component/s Classlib [ 12310560 ]
        Description I've reproduced the problem once from 54 runs. I've reproduced the problem once from 54 runs:

        ....
        SIGSEGV in VM code.
        Stack trace:
        Time: 2.182

        OK (4 tests)

        [the process hangs]
        Ilya Berezhniuk added a comment -

        I've checked this test with latest VM build on ia32 Linux SuSE 9.

        I couldn't reproduce this crash on 200 runs neither for debug build nor for release build.
        I think this issue can now be closed.

        Gregory Shimansky made changes -
        Assignee Gregory Shimansky [ gshimansky ]
        Gregory Shimansky added a comment -

        I ran the test for the night. It passed 4178 times. So I think we can close this bug as not reproducible.

        Gregory Shimansky made changes -
        Status Open [ 1 ] Closed [ 6 ]
        Resolution Cannot Reproduce [ 5 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Closed Closed
        187d 8h 55m 1 Gregory Shimansky 05/Jun/07 10:13

          People

          • Assignee:
            Gregory Shimansky
            Reporter:
            Alexei Fedotov
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development