Harmony
  1. Harmony
  2. HARMONY-2366

[drlvm][unit] org.apache.harmony.luni.tests.java.lang.ThreadTest.test_interrupt() deadlocks intermittently

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: DRLVM
    • Labels:
      None
    • Environment:
      Win XP, Pentium-M JIT/interpreter, r480584
    • Estimated Complexity:
      Moderate

      Description

      $subj

        Issue Links

          Activity

          Alexei Fedotov created issue -
          Alexei Fedotov made changes -
          Field Original Value New Value
          Environment Win XP, Pentium-M JIT/interpreter Win XP, Pentium-M JIT/interpreter, r480584
          Alexei Fedotov added a comment -

          Reproduced on r480317 as well.

          Alexei Fedotov added a comment -

          I suggest attaching MSVC debugger to the process - it gives a picture of two threads deadlocked on standard synchronization promitives.

          Salikh Zakirov added a comment -

          The fix for this issue has been available for quite some time: HARMONY-2219 (a split out part of original patch of HARMONY-1789)

          Salikh Zakirov made changes -
          Link This issue duplicates HARMONY-2219 [ HARMONY-2219 ]
          Alexei Fedotov added a comment -

          Ran test 144 times. Verifed.

          Alexei Fedotov made changes -
          Link This issue is duplicated by HARMONY-2219 [ HARMONY-2219 ]
          Alexey Petrenko added a comment -

          Closed as duplicate of HARMONY-2219

          Alexey Petrenko made changes -
          Resolution Fixed [ 1 ]
          Assignee Alexey Petrenko [ cap ]
          Status Open [ 1 ] Closed [ 6 ]
          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Closed Closed
          7d 2h 4m 1 Alexey Petrenko 06/Dec/06 21:53

            People

            • Assignee:
              Alexey Petrenko
              Reporter:
              Alexei Fedotov
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development